summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-dnspython.inc20
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb22
2 files changed, 20 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-dnspython.inc b/meta-python/recipes-devtools/python/python-dnspython.inc
deleted file mode 100644
index 84502affe1..0000000000
--- a/meta-python/recipes-devtools/python/python-dnspython.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
5
6SRC_URI[md5sum] = "bc9ca3b3a82164667d5730ec6d5248a2"
7SRC_URI[sha256sum] = "36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c558e01"
8
9PYPI_PACKAGE_EXT = "zip"
10
11inherit pypi
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-crypt \
15 ${PYTHON_PN}-io \
16 ${PYTHON_PN}-math \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19 ${PYTHON_PN}-threading \
20"
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
index ce4dfdc74a..cb255442f4 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
@@ -1,2 +1,20 @@
1inherit setuptools3 1DESCRIPTION = "DNS toolkit for Python"
2require python-dnspython.inc 2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
5
6SRC_URI[md5sum] = "bc9ca3b3a82164667d5730ec6d5248a2"
7SRC_URI[sha256sum] = "36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c558e01"
8
9PYPI_PACKAGE_EXT = "zip"
10
11inherit pypi setuptools3
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-crypt \
15 ${PYTHON_PN}-io \
16 ${PYTHON_PN}-math \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19 ${PYTHON_PN}-threading \
20"