diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-dbusmock/0001-Don-t-use-gobject-introspection-for-bindings.patch | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-dbusmock_0.10.1.bb | 1 |
2 files changed, 0 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbusmock/0001-Don-t-use-gobject-introspection-for-bindings.patch b/meta-python/recipes-devtools/python/python-dbusmock/0001-Don-t-use-gobject-introspection-for-bindings.patch deleted file mode 100644 index f3ab53c546..0000000000 --- a/meta-python/recipes-devtools/python/python-dbusmock/0001-Don-t-use-gobject-introspection-for-bindings.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 29960f2fce7ab42ed0a1bf8ce96499fdb6eedf3c Mon Sep 17 00:00:00 2001 | ||
2 | From: Simon Busch <simon.busch@lge.com> | ||
3 | Date: Tue, 25 Mar 2014 15:28:54 +0100 | ||
4 | Subject: [PATCH] Don't use gobject introspection for bindings | ||
5 | |||
6 | In our environment we're not providing the glib python bindings through | ||
7 | introspection but just pygobject so we need to use the right import. | ||
8 | |||
9 | Signed-off-by: Simon Busch <simon.busch@lge.com> | ||
10 | --- | ||
11 | dbusmock/__main__.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/dbusmock/__main__.py b/dbusmock/__main__.py | ||
15 | index 44b63fb..bfd089c 100644 | ||
16 | --- a/dbusmock/__main__.py | ||
17 | +++ b/dbusmock/__main__.py | ||
18 | @@ -51,7 +51,7 @@ def parse_args(): | ||
19 | |||
20 | if __name__ == '__main__': | ||
21 | import dbus.mainloop.glib | ||
22 | - from gi.repository import GLib | ||
23 | + import glib as GLib | ||
24 | |||
25 | args = parse_args() | ||
26 | dbus.mainloop.glib.DBusGMainLoop(set_as_default=True) | ||
27 | -- | ||
28 | 1.7.9.5 | ||
29 | |||
diff --git a/meta-python/recipes-devtools/python/python-dbusmock_0.10.1.bb b/meta-python/recipes-devtools/python/python-dbusmock_0.10.1.bb index b24794395a..2520bfc953 100644 --- a/meta-python/recipes-devtools/python/python-dbusmock_0.10.1.bb +++ b/meta-python/recipes-devtools/python/python-dbusmock_0.10.1.bb | |||
@@ -14,7 +14,6 @@ SRC_URI[md5sum] = "7370d325c4a75494dd71885ca65b79e8" | |||
14 | SRC_URI[sha256sum] = "03aadc93bdc26ea18d4d78fcff7b6cb34f4e18623bc5cc41cf9539d663cee11e" | 14 | SRC_URI[sha256sum] = "03aadc93bdc26ea18d4d78fcff7b6cb34f4e18623bc5cc41cf9539d663cee11e" |
15 | 15 | ||
16 | SRC_URI += " \ | 16 | SRC_URI += " \ |
17 | file://0001-Don-t-use-gobject-introspection-for-bindings.patch \ | ||
18 | file://0001-Add-functionality-to-add-own-objects-to-internal-obj.patch \ | 17 | file://0001-Add-functionality-to-add-own-objects-to-internal-obj.patch \ |
19 | file://0002-Add-possibility-to-import-templates-from-packages.patch \ | 18 | file://0002-Add-possibility-to-import-templates-from-packages.patch \ |
20 | " | 19 | " |