summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-requests.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.7.0.bb18
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.9.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.9.1.bb2
4 files changed, 15 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-requests.inc b/meta-python/recipes-devtools/python/python-requests.inc
new file mode 100644
index 0000000000..ebce2539c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-requests.inc
@@ -0,0 +1,9 @@
1DESCRIPTION = "Python HTTP for Humans."
2HOMEPAGE = "http://python-requests.org"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e"
5
6SRC_URI[md5sum] = "0b7f480d19012ec52bab78292efd976d"
7SRC_URI[sha256sum] = "c577815dd00f1394203fc44eb979724b098f88264a9ef898ee45b8e5e9cf587f"
8
9RDEPENDS_${PN} = "${PYTHON_PN}-email ${PYTHON_PN}-json ${PYTHON_PN}-netserver"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.7.0.bb b/meta-python/recipes-devtools/python/python-requests_2.7.0.bb
deleted file mode 100644
index ac47202acc..0000000000
--- a/meta-python/recipes-devtools/python/python-requests_2.7.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1DESCRIPTION = "Python HTTP for Humans."
2HOMEPAGE = "http://python-requests.org"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e"
6
7SRCNAME = "requests"
8
9SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "29b173fd5fa572ec0764d1fd7b527260"
12SRC_URI[sha256sum] = "398a3db6d61899d25fd4a06c6ca12051b0ce171d705decd7ed5511517b4bb93d"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} = "python-email python-json python-netserver python-zlib"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.9.1.bb b/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
new file mode 100644
index 0000000000..acc8c1665e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
@@ -0,0 +1,4 @@
1inherit pypi
2require python-requests.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-zlib" \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.9.1.bb b/meta-python/recipes-devtools/python/python3-requests_2.9.1.bb
new file mode 100644
index 0000000000..c2eb056eec
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests_2.9.1.bb
@@ -0,0 +1,2 @@
1inherit pypi3
2require python-requests.inc