diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-robotframework-seriallibrary/e31d5fdf2ea00ac6349e64580a20816783064dd4.patch | 45 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.4.3.bb (renamed from meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb) | 7 |
2 files changed, 2 insertions, 50 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary/e31d5fdf2ea00ac6349e64580a20816783064dd4.patch b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary/e31d5fdf2ea00ac6349e64580a20816783064dd4.patch deleted file mode 100644 index 21e97fd93a..0000000000 --- a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary/e31d5fdf2ea00ac6349e64580a20816783064dd4.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From e31d5fdf2ea00ac6349e64580a20816783064dd4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hideki Takeoka <hideki.takeoka@smartfrog.com> | ||
3 | Date: Sun, 25 Aug 2019 19:25:00 +0200 | ||
4 | Subject: [PATCH] Update setup.py for python3.7+ support | ||
5 | |||
6 | --- | ||
7 | setup.py | 9 +++++---- | ||
8 | src/SerialLibrary/version.py | 3 +++ | ||
9 | 2 files changed, 8 insertions(+), 4 deletions(-) | ||
10 | |||
11 | diff --git a/setup.py b/setup.py | ||
12 | index 4c34705..70bb1af 100644 | ||
13 | --- a/setup.py | ||
14 | +++ b/setup.py | ||
15 | @@ -1,6 +1,5 @@ | ||
16 | #!/usr/bin/env python | ||
17 | |||
18 | -from imp import load_source | ||
19 | from os.path import abspath, dirname, join | ||
20 | from sys import platform | ||
21 | |||
22 | @@ -18,9 +17,11 @@ | ||
23 | |||
24 | |||
25 | CURDIR = dirname(abspath(__file__)) | ||
26 | -VERSION = load_source( | ||
27 | - 'version', 'version', | ||
28 | - open(join(CURDIR, 'src', 'SerialLibrary', 'version.py'))).VERSION | ||
29 | + | ||
30 | +with open(join(CURDIR, 'src', 'SerialLibrary', 'version.py')) as f: | ||
31 | + exec(f.read()) | ||
32 | + VERSION = get_version() | ||
33 | + | ||
34 | README = open(join(CURDIR, 'README.rst')).read() | ||
35 | CLASSIFIERS = '\n'.join( | ||
36 | map(' :: '.join, [ | ||
37 | diff --git a/src/SerialLibrary/version.py b/src/SerialLibrary/version.py | ||
38 | index 6ce65c4..19831bc 100644 | ||
39 | --- a/src/SerialLibrary/version.py | ||
40 | +++ b/src/SerialLibrary/version.py | ||
41 | @@ -1 +1,4 @@ | ||
42 | VERSION = (0, 3, 1) | ||
43 | + | ||
44 | +def get_version(): | ||
45 | + return VERSION; | ||
diff --git a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.4.3.bb index d9465af081..4ad5c3601d 100644 --- a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb +++ b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.4.3.bb | |||
@@ -1,17 +1,14 @@ | |||
1 | SUMMARY = "Robot Framework test library for serial connection" | 1 | SUMMARY = "Robot Framework test library for serial connection" |
2 | HOMEPAGE = "https://github.com/whosaysni/robotframework-seriallibrary" | 2 | HOMEPAGE = "https://github.com/whosaysni/robotframework-seriallibrary" |
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" | 4 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=1af2e051b493d9552af443cf2f99d480" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "b7c9565d54c30df7cd3f3c0e29adffa3" | 6 | SRC_URI[sha256sum] = "f20befe5c1106dd8ddca9f60a2f18bf5ec7d5f06f6f09a03fa66bae54777e6bb" |
7 | SRC_URI[sha256sum] = "256ad60fc0b7df4be44d82c302f5ed8fad4935cda99e4b45942e3c88179d1e19" | ||
8 | 7 | ||
9 | PYPI_PACKAGE = "robotframework-seriallibrary" | 8 | PYPI_PACKAGE = "robotframework-seriallibrary" |
10 | 9 | ||
11 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 |
12 | 11 | ||
13 | SRC_URI += "file://e31d5fdf2ea00ac6349e64580a20816783064dd4.patch" | ||
14 | |||
15 | RDEPENDS:${PN} += " \ | 12 | RDEPENDS:${PN} += " \ |
16 | ${PYTHON_PN}-pyserial \ | 13 | ${PYTHON_PN}-pyserial \ |
17 | ${PYTHON_PN}-robotframework \ | 14 | ${PYTHON_PN}-robotframework \ |