diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-xmltodict/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest b/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb b/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb index 00aa818096..d078883249 100644 --- a/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb +++ b/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb | |||
@@ -9,4 +9,17 @@ SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d16 | |||
9 | 9 | ||
10 | PYPI_PACKAGE = "xmltodict" | 10 | PYPI_PACKAGE = "xmltodict" |
11 | 11 | ||
12 | inherit pypi setuptools3 | 12 | inherit pypi setuptools3 ptest |
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS_${PN}-ptest += " \ | ||
19 | ${PYTHON_PN}-pytest \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/tests | ||
24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
25 | } | ||