summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch31
-rw-r--r--meta-python/recipes-devtools/python/python-daemon_2.1.2.bb27
-rw-r--r--meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb18
-rw-r--r--meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb13
4 files changed, 89 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch b/meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch
new file mode 100644
index 0000000000..dbb8407186
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch
@@ -0,0 +1,31 @@
1From 0981eee9f0198c2045dc0eaa78a005d06fc7bfe4 Mon Sep 17 00:00:00 2001
2From: Carlos Eduardo Moreira dos Santos <cems@cemshost.com.br>
3Date: Tue, 28 Mar 2017 18:23:44 -0300
4Subject: [PATCH] Workaround for issue 2 [1]
5
6[1] https://pagure.io/python-daemon/issue/2
7---
8 version.py | 7 ++++---
9 1 file changed, 4 insertions(+), 3 deletions(-)
10
11diff --git a/version.py b/version.py
12index d58422a377ee..293e2d64c2b7 100644
13--- a/version.py
14+++ b/version.py
15@@ -648,9 +648,10 @@ class ChangelogAwareDistribution(distutils.dist.Distribution, object):
16
17 @lru_cache(maxsize=128)
18 def get_version_info(self):
19- changelog_path = get_changelog_path(self)
20- version_info = generate_version_info_from_changelog(changelog_path)
21- return version_info
22+ return {
23+ 'version': '2.1.2',
24+ 'maintainer': 'Ben Finney'
25+ }
26
27 def get_version(self):
28 version_info = self.get_version_info()
29--
302.7.4
31
diff --git a/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
new file mode 100644
index 0000000000..4c18e2bad5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Library to implement a well-behaved Unix daemon process"
2HOMEPAGE = "https://pagure.io/python-daemon/"
3SECTION = "devel/python"
4
5DEPENDS = "python-docutils"
6RDEPENDS_${PN} = "python-docutils \
7 python-lockfile (>= 0.10) \
8 python-resource \
9"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
13
14inherit pypi setuptools
15
16SRC_URI[md5sum] = "9c57343d81f2a96c51cffeab982b04d2"
17SRC_URI[sha256sum] = "261c859be5c12ae7d4286dc6951e87e9e1a70a882a8b41fd926efc1ec4214f73"
18
19# Fix for build error in Yocto:
20# i = p.rfind('/') + 1
21# AttributeError: 'NoneType' object has no attribute 'rfind'
22#S = "${WORKDIR}/python-daemon"
23SRC_URI_append = " \
24 file://0001-Workaround-for-issue-2-1.patch \
25"
26
27PYPI_PACKAGE = "python-daemon"
diff --git a/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb b/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb
new file mode 100644
index 0000000000..68436a1a54
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=35a23d42b615470583563132872c97d6"
6
7DEPENDS = "python"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/docutils/docutils-${PV}.tar.gz"
10SRC_URI[md5sum] = "2f4bee6451958252f7bec71f18b05be3"
11SRC_URI[sha256sum] = "3caee0bcb2a49fdf24fcfa70849a60abb7a181aa68b030f7cb7494096181830c"
12
13S = "${WORKDIR}/docutils-${PV}"
14
15inherit distutils
16
17BBCLASSEXTEND = "native"
18
diff --git a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
new file mode 100644
index 0000000000..cd15760d46
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
@@ -0,0 +1,13 @@
1DESCRIPTION = "Platform-independent file locking module"
2HOMEPAGE = "http://launchpad.net/pylockfile"
3SECTION = "devel/python"
4
5RDEPENDS_${PN} = "python-threading"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
9
10inherit pypi setuptools
11
12SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
13SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"