summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb31
2 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index d7f136e8ee..4ce9616302 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -46,7 +46,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
46 python3-aws-iot-device-sdk-python \ 46 python3-aws-iot-device-sdk-python \
47 python3-babel \ 47 python3-babel \
48 python3-backcall \ 48 python3-backcall \
49 python3-backports-functools-lru-cache \
50 python3-bandit \ 49 python3-bandit \
51 python3-bcrypt \ 50 python3-bcrypt \
52 python3-beautifulsoup4 \ 51 python3-beautifulsoup4 \
@@ -482,7 +481,6 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\
482 python3-markupsafe-ptest \ 481 python3-markupsafe-ptest \
483 python3-ansicolors-ptest \ 482 python3-ansicolors-ptest \
484 python3-appdirs-ptest \ 483 python3-appdirs-ptest \
485 python3-backports-functools-lru-cache-ptest \
486 python3-bcrypt-ptest \ 484 python3-bcrypt-ptest \
487 python3-betamax-ptest \ 485 python3-betamax-ptest \
488 python3-blinker-ptest \ 486 python3-blinker-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb
deleted file mode 100644
index 392c044bfc..0000000000
--- a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.4.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Backport of functools.lru_cache from Python 3.3"
2HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7PYPI_PACKAGE = "backports.functools_lru_cache"
8
9SRC_URI[sha256sum] = "d5ed2169378b67d3c545e5600d363a923b09c456dab1593914935a68ad478271"
10
11DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
12
13inherit pypi setuptools3 ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS:${PN} += "\
29 ${PYTHON_PN}-pickle \
30 ${PYTHON_PN}-threading \
31 "