summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-asn1crypto.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb6
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto.inc b/meta-python/recipes-devtools/python/python-asn1crypto.inc
index 41b7342194..92c71989d8 100644
--- a/meta-python/recipes-devtools/python/python-asn1crypto.inc
+++ b/meta-python/recipes-devtools/python/python-asn1crypto.inc
@@ -10,4 +10,16 @@ SRC_URI[md5sum] = "97d54665c397b72b165768398dfdd876"
10SRC_URI[sha256sum] = "0874981329cfebb366d6584c3d16e913f2a0eb026c9463efcc4aaf42a9d94d70" 10SRC_URI[sha256sum] = "0874981329cfebb366d6584c3d16e913f2a0eb026c9463efcc4aaf42a9d94d70"
11 11
12inherit pypi 12inherit pypi
13
14RDEPENDS_${PN}_class-target += " \
15 ${PYTHON_PN}-codecs \
16 ${PYTHON_PN}-crypt \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-io \
20 ${PYTHON_PN}-netclient \
21 ${PYTHON_PN}-textutils \
22 ${PYTHON_PN}-subprocess \
23"
24
13BBCLASSEXTEND = "native" 25BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb
index 30f3404173..bc672158a9 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb
@@ -1,2 +1,8 @@
1inherit setuptools3 1inherit setuptools3
2require python-asn1crypto.inc 2require python-asn1crypto.inc
3
4RDEPENDS_${PN}_class-target += " \
5 ${PYTHON_PN}-enum \
6 ${PYTHON_PN}-selectors \
7 ${PYTHON_PN}-shell \
8"