diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pluggy/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pluggy_0.13.1.bb | 27 |
2 files changed, 0 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pluggy/run-ptest b/meta-python/recipes-devtools/python/python3-pluggy/run-ptest deleted file mode 100644 index b63c4de0d9..0000000000 --- a/meta-python/recipes-devtools/python/python3-pluggy/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-pluggy_0.13.1.bb b/meta-python/recipes-devtools/python/python3-pluggy_0.13.1.bb deleted file mode 100644 index d3e0365ca1..0000000000 --- a/meta-python/recipes-devtools/python/python3-pluggy_0.13.1.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | SUMMARY = "Plugin and hook calling mechanisms for python" | ||
2 | HOMEPAGE = "https://github.com/pytest-dev/pluggy" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2" | ||
5 | |||
6 | SRC_URI[md5sum] = "7f610e28b8b34487336b585a3dfb803d" | ||
7 | SRC_URI[sha256sum] = "15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0" | ||
8 | |||
9 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
10 | RDEPENDS_${PN} += "${PYTHON_PN}-importlib-metadata \ | ||
11 | ${PYTHON_PN}-more-itertools \ | ||
12 | " | ||
13 | |||
14 | inherit pypi ptest setuptools3 | ||
15 | |||
16 | SRC_URI += " \ | ||
17 | file://run-ptest \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS_${PN}-ptest += " \ | ||
21 | ${PYTHON_PN}-pytest \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | install -d ${D}${PTEST_PATH}/testing | ||
26 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/ | ||
27 | } | ||