summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent/not-final.patch16
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb3
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent/not-final.patch b/meta-python/recipes-devtools/python/python3-gevent/not-final.patch
new file mode 100644
index 0000000000..444a195da4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gevent/not-final.patch
@@ -0,0 +1,16 @@
1gevent fails to build with Cython 3.0.10. As per
2https://github.com/gevent/gevent/issues/2031, removing the
3cython.final decorator works around this.
4
5Upstream-Status: Pending
6Signed-off-by: Ross Burton <ross.burton@arm.com>
7
8--- a/src/gevent/_gevent_cqueue.pxd
9+++ b/src/gevent/_gevent_cqueue.pxd
10@@ -75,7 +75,6 @@ cdef class ItemWaiter(Waiter):
11 cdef readonly Queue queue
12
13
14-@cython.final
15 cdef class UnboundQueue(Queue):
16 pass
diff --git a/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
index fbdbf8ccc7..0a74f52820 100644
--- a/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
@@ -13,7 +13,8 @@ RDEPENDS:${PN} = "python3-greenlet \
13 python3-zopeinterface \ 13 python3-zopeinterface \
14 " 14 "
15 15
16SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch" 16SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch \
17 file://not-final.patch"
17 18
18SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056" 19SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
19 20