diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-msgpack/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-msgpack/run-ptest b/meta-python/recipes-devtools/python/python3-msgpack/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-msgpack/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb b/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb index 7cfaf1c513..6d7e7a0dcd 100644 --- a/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb +++ b/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb | |||
@@ -3,7 +3,7 @@ LICENSE = "Apache-2.0" | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751" |
4 | 4 | ||
5 | PYPI_PACKAGE = "msgpack" | 5 | PYPI_PACKAGE = "msgpack" |
6 | inherit pypi setuptools3 | 6 | inherit pypi setuptools3 ptest |
7 | 7 | ||
8 | SRC_URI[md5sum] = "ba46fdee995565f40e332bd7eea882f1" | 8 | SRC_URI[md5sum] = "ba46fdee995565f40e332bd7eea882f1" |
9 | SRC_URI[sha256sum] = "ea3c2f859346fcd55fc46e96885301d9c2f7a36d453f5d8f2967840efa1e1830" | 9 | SRC_URI[sha256sum] = "ea3c2f859346fcd55fc46e96885301d9c2f7a36d453f5d8f2967840efa1e1830" |
@@ -13,3 +13,16 @@ RDEPENDS_${PN}_class-target += "\ | |||
13 | " | 13 | " |
14 | 14 | ||
15 | BBCLASSEXTEND = "native nativesdk" | 15 | BBCLASSEXTEND = "native nativesdk" |
16 | |||
17 | SRC_URI += " \ | ||
18 | file://run-ptest \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS_${PN}-ptest += " \ | ||
22 | ${PYTHON_PN}-pytest \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/test | ||
27 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ | ||
28 | } | ||