diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-decorator.inc | 19 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb | 21 |
2 files changed, 19 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator.inc b/meta-python/recipes-devtools/python/python-decorator.inc deleted file mode 100644 index 3faee39133..0000000000 --- a/meta-python/recipes-devtools/python/python-decorator.inc +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | SUMMARY = "Python decorator utilities" | ||
2 | DESCRIPTION = "\ | ||
3 | The aim of the decorator module it to simplify the usage of decorators \ | ||
4 | for the average programmer, and to popularize decorators by showing \ | ||
5 | various non-trivial examples. Of course, as all techniques, decorators \ | ||
6 | can be abused and you should not try to solve every problem with a \ | ||
7 | decorator, just because you can." | ||
8 | |||
9 | LICENSE = "BSD-2-Clause" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22" | ||
11 | |||
12 | SRC_URI[md5sum] = "d83c624cce93e6bdfab144821b526e1d" | ||
13 | SRC_URI[sha256sum] = "e3a62f0520172440ca0dcc823749319382e377f37f140a0b99ef45fecb84bfe7" | ||
14 | |||
15 | inherit pypi | ||
16 | |||
17 | RDEPENDS_${PN} += "\ | ||
18 | ${PYTHON_PN}-stringold \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb b/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb index 844cbdc9a9..23d0cf2181 100644 --- a/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb +++ b/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb | |||
@@ -1,2 +1,19 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Python decorator utilities" |
2 | require python-decorator.inc | 2 | DESCRIPTION = "\ |
3 | The aim of the decorator module it to simplify the usage of decorators \ | ||
4 | for the average programmer, and to popularize decorators by showing \ | ||
5 | various non-trivial examples. Of course, as all techniques, decorators \ | ||
6 | can be abused and you should not try to solve every problem with a \ | ||
7 | decorator, just because you can." | ||
8 | |||
9 | LICENSE = "BSD-2-Clause" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22" | ||
11 | |||
12 | SRC_URI[md5sum] = "d83c624cce93e6bdfab144821b526e1d" | ||
13 | SRC_URI[sha256sum] = "e3a62f0520172440ca0dcc823749319382e377f37f140a0b99ef45fecb84bfe7" | ||
14 | |||
15 | inherit pypi setuptools3 | ||
16 | |||
17 | RDEPENDS_${PN} += "\ | ||
18 | ${PYTHON_PN}-stringold \ | ||
19 | " | ||