summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-decorator.inc19
-rw-r--r--meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb21
2 files changed, 19 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator.inc b/meta-python/recipes-devtools/python/python-decorator.inc
deleted file mode 100644
index 3faee39133..0000000000
--- a/meta-python/recipes-devtools/python/python-decorator.inc
+++ /dev/null
@@ -1,19 +0,0 @@
1SUMMARY = "Python decorator utilities"
2DESCRIPTION = "\
3The aim of the decorator module it to simplify the usage of decorators \
4for the average programmer, and to popularize decorators by showing \
5various non-trivial examples. Of course, as all techniques, decorators \
6can be abused and you should not try to solve every problem with a \
7decorator, just because you can."
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
11
12SRC_URI[md5sum] = "d83c624cce93e6bdfab144821b526e1d"
13SRC_URI[sha256sum] = "e3a62f0520172440ca0dcc823749319382e377f37f140a0b99ef45fecb84bfe7"
14
15inherit pypi
16
17RDEPENDS_${PN} += "\
18 ${PYTHON_PN}-stringold \
19 "
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb b/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
index 844cbdc9a9..23d0cf2181 100644
--- a/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
@@ -1,2 +1,19 @@
1inherit setuptools3 1SUMMARY = "Python decorator utilities"
2require python-decorator.inc 2DESCRIPTION = "\
3The aim of the decorator module it to simplify the usage of decorators \
4for the average programmer, and to popularize decorators by showing \
5various non-trivial examples. Of course, as all techniques, decorators \
6can be abused and you should not try to solve every problem with a \
7decorator, just because you can."
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
11
12SRC_URI[md5sum] = "d83c624cce93e6bdfab144821b526e1d"
13SRC_URI[sha256sum] = "e3a62f0520172440ca0dcc823749319382e377f37f140a0b99ef45fecb84bfe7"
14
15inherit pypi setuptools3
16
17RDEPENDS_${PN} += "\
18 ${PYTHON_PN}-stringold \
19 "