summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-rfc3986-validator.inc23
-rw-r--r--meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb25
2 files changed, 23 insertions, 25 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator.inc b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
deleted file mode 100644
index 71f7a7904f..0000000000
--- a/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Pure python rfc3986 validator"
2HOMEPAGE = "https://github.com/naimetti/rfc3986-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3986-validator:"
7
8SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95"
9SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055"
10
11PYPI_PACKAGE = "rfc3986_validator"
12
13inherit pypi
14
15SRC_URI_append = " \
16 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
17"
18
19RDEPENDS_${PN} += "\
20 python3-core \
21"
22
23BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb
index 6491308cbb..ed668fba98 100644
--- a/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb
@@ -1,2 +1,23 @@
1inherit setuptools3 1SUMMARY = "Pure python rfc3986 validator"
2require python-rfc3986-validator.inc \ No newline at end of file 2HOMEPAGE = "https://github.com/naimetti/rfc3986-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3986-validator:"
7
8SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95"
9SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055"
10
11PYPI_PACKAGE = "rfc3986_validator"
12
13inherit pypi setuptools3
14
15SRC_URI_append = " \
16 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
17"
18
19RDEPENDS_${PN} += "\
20 python3-core \
21"
22
23BBCLASSEXTEND = "native nativesdk"