diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch | 33 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb | 7 |
2 files changed, 37 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch new file mode 100644 index 0000000000..941bed3d73 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 3484bdfa7adbaebcf8bb8e7d4820f64b12717932 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Fri, 29 Jul 2016 15:37:18 +0800 | ||
4 | Subject: [PATCH] python-mccabe: remove unnecessary setup_requires | ||
5 | pytest-runner | ||
6 | |||
7 | * Remove setup_requires pytest-runner as the | ||
8 | setup_requires pytest-runner actually is not | ||
9 | used for pytest which only in do_compile phase | ||
10 | via setup.py build | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
15 | --- | ||
16 | setup.py | 1 - | ||
17 | 1 file changed, 1 deletion(-) | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index e59903d..bf2aaba 100644 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -33,7 +33,6 @@ setup( | ||
24 | license='Expat license', | ||
25 | py_modules=['mccabe'], | ||
26 | zip_safe=False, | ||
27 | - setup_requires=['pytest-runner'], | ||
28 | tests_require=['pytest'], | ||
29 | entry_points={ | ||
30 | 'flake8.extension': [ | ||
31 | -- | ||
32 | 2.8.1 | ||
33 | |||
diff --git a/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb b/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb index ba966ebc1d..a86d158007 100644 --- a/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb +++ b/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb | |||
@@ -3,14 +3,15 @@ HOMEPAGE = "https://github.com/dreamhost/cliff" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://README.rst;md5=f8b50fba1711ecac6bcdb6324f85a66d" | 4 | LIC_FILES_CHKSUM = "file://README.rst;md5=f8b50fba1711ecac6bcdb6324f85a66d" |
5 | 5 | ||
6 | SRC_URI += " \ | ||
7 | file://0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch \ | ||
8 | " | ||
9 | |||
6 | SRC_URI[md5sum] = "8c425db05f310adcd4bb174b991f26f5" | 10 | SRC_URI[md5sum] = "8c425db05f310adcd4bb174b991f26f5" |
7 | SRC_URI[sha256sum] = "9a2b12ebd876e77c72e41ebf401cc2e7c5b566649d50105ca49822688642207b" | 11 | SRC_URI[sha256sum] = "9a2b12ebd876e77c72e41ebf401cc2e7c5b566649d50105ca49822688642207b" |
8 | 12 | ||
9 | inherit pypi setuptools | 13 | inherit pypi setuptools |
10 | 14 | ||
11 | DEPENDS += " \ | ||
12 | python-pytest-runner" | ||
13 | |||
14 | RDEPENDS_${PN} += " \ | 15 | RDEPENDS_${PN} += " \ |
15 | python-prettytable \ | 16 | python-prettytable \ |
16 | python-cmd2 \ | 17 | python-cmd2 \ |