summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch33
-rw-r--r--meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb7
2 files changed, 37 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
new file mode 100644
index 0000000000..941bed3d73
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
@@ -0,0 +1,33 @@
1From 3484bdfa7adbaebcf8bb8e7d4820f64b12717932 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 29 Jul 2016 15:37:18 +0800
4Subject: [PATCH] python-mccabe: remove unnecessary setup_requires
5 pytest-runner
6
7* Remove setup_requires pytest-runner as the
8 setup_requires pytest-runner actually is not
9 used for pytest which only in do_compile phase
10 via setup.py build
11
12Upstream-Status: Pending
13
14Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
15---
16 setup.py | 1 -
17 1 file changed, 1 deletion(-)
18
19diff --git a/setup.py b/setup.py
20index e59903d..bf2aaba 100644
21--- a/setup.py
22+++ b/setup.py
23@@ -33,7 +33,6 @@ setup(
24 license='Expat license',
25 py_modules=['mccabe'],
26 zip_safe=False,
27- setup_requires=['pytest-runner'],
28 tests_require=['pytest'],
29 entry_points={
30 'flake8.extension': [
31--
322.8.1
33
diff --git a/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb b/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb
index ba966ebc1d..a86d158007 100644
--- a/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb
@@ -3,14 +3,15 @@ HOMEPAGE = "https://github.com/dreamhost/cliff"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://README.rst;md5=f8b50fba1711ecac6bcdb6324f85a66d" 4LIC_FILES_CHKSUM = "file://README.rst;md5=f8b50fba1711ecac6bcdb6324f85a66d"
5 5
6SRC_URI += " \
7 file://0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch \
8"
9
6SRC_URI[md5sum] = "8c425db05f310adcd4bb174b991f26f5" 10SRC_URI[md5sum] = "8c425db05f310adcd4bb174b991f26f5"
7SRC_URI[sha256sum] = "9a2b12ebd876e77c72e41ebf401cc2e7c5b566649d50105ca49822688642207b" 11SRC_URI[sha256sum] = "9a2b12ebd876e77c72e41ebf401cc2e7c5b566649d50105ca49822688642207b"
8 12
9inherit pypi setuptools 13inherit pypi setuptools
10 14
11DEPENDS += " \
12 python-pytest-runner"
13
14RDEPENDS_${PN} += " \ 15RDEPENDS_${PN} += " \
15 python-prettytable \ 16 python-prettytable \
16 python-cmd2 \ 17 python-cmd2 \