summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch19
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb (renamed from meta-python/recipes-devtools/python/python-pyopenssl_0.13.bb)10
2 files changed, 5 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch b/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch
deleted file mode 100644
index c386e9ccd6..0000000000
--- a/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1diff -Naur pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c pyOpenSSL-0.13/OpenSSL/crypto/crl.c
2--- pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c 2011-09-02 17:46:13.000000000 +0200
3+++ pyOpenSSL-0.13/OpenSSL/crypto/crl.c 2015-03-26 20:53:08.984999223 +0100
4@@ -3,6 +3,7 @@
5 #include "crypto.h"
6
7
8+#if 0
9 static X509_REVOKED * X509_REVOKED_dup(X509_REVOKED *orig) {
10 X509_REVOKED *dupe = NULL;
11
12@@ -32,6 +33,7 @@
13 dupe->sequence = orig->sequence;
14 return dupe;
15 }
16+#endif
17
18 static char crypto_CRL_get_revoked_doc[] = "\n\
19 Return revoked portion of the CRL structure (by value\n\
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_0.13.bb b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
index cf9d73e636..694da275e2 100644
--- a/meta-python/recipes-devtools/python/python-pyopenssl_0.13.bb
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
@@ -6,13 +6,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6 6
7SRCNAME = "pyOpenSSL" 7SRCNAME = "pyOpenSSL"
8 8
9DEPENDS = "openssl" 9DEPENDS = "openssl python-cryptography"
10PE = "1" 10PE = "1"
11 11
12SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz \ 12SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
13 file://x509_revoked_dup.patch" 13
14SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929" 14SRC_URI[md5sum] = "f447644afcbd5f0a1f47350fec63a4c6"
15SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b" 15SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984bc0d672"
16 16
17S = "${WORKDIR}/${SRCNAME}-${PV}" 17S = "${WORKDIR}/${SRCNAME}-${PV}"
18 18