diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-betamax/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb | 23 |
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-betamax/run-ptest b/meta-python/recipes-devtools/python/python3-betamax/run-ptest new file mode 100644 index 0000000000..b63c4de0d9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-betamax/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb b/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb new file mode 100644 index 0000000000..ef654e9172 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "VCR imitation for python requests" | ||
2 | HOMEPAGE = "https://github.com/betamaxpy/betamax" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=61c15f0c146c5fb1a8ce8ba2f310d73c" | ||
5 | |||
6 | SRC_URI += " \ | ||
7 | file://run-ptest \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "b8182d43a200fc126a3bf7555626f964" | ||
11 | SRC_URI[sha256sum] = "5bf004ceffccae881213fb722f34517166b84a34919b92ffc14d1dbd050b71c2" | ||
12 | |||
13 | inherit pypi setuptools3 ptest | ||
14 | |||
15 | RDEPENDS_${PN}-ptest += " \ | ||
16 | ${PYTHON_PN}-pytest \ | ||
17 | ${PYTHON_PN}-requests \ | ||
18 | " | ||
19 | |||
20 | do_install_ptest() { | ||
21 | install -d ${D}${PTEST_PATH}/tests | ||
22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
23 | } | ||