diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 58 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio-tools_1.14.1.bb | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio-tools_1.35.0.bb (renamed from meta-python/recipes-devtools/python/python-grpcio-tools.inc) | 14 |
3 files changed, 66 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch new file mode 100644 index 0000000000..aef67b5748 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From 9b2f1d400db8b8d0045f5a58a748a2dc52b5c9ef Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 17 Feb 2021 13:38:55 -0800 | ||
4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options | ||
5 | |||
6 | EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX | ||
7 | so using -std=c++11 or -std=gnu99 together will cause | ||
8 | build time errors espcially with clang | ||
9 | |||
10 | Keep '-std=c++11' to fix native build error | ||
11 | with old gcc (such as gcc 5.4.0 on ubuntu 16.04), for clang | ||
12 | we will remove them through GRPC_PYTHON_CFLAGS at do_compile | ||
13 | in bb recipe. | ||
14 | |||
15 | While export CC="gcc ", cc_args is None, it will | ||
16 | cause subprocess.Popen always return 1. On centos 8, if you don't | ||
17 | install package libatomic, there will be a native build error | ||
18 | `cannot find /usr/lib64/libatomic.so.1.2.0'. | ||
19 | |||
20 | Add no harm '-g' to cc_args if cc_args is empty. | ||
21 | |||
22 | Upstream-Status: Inappropriate [oe specific] | ||
23 | |||
24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
25 | --- | ||
26 | setup.py | 9 ++++++--- | ||
27 | 1 file changed, 6 insertions(+), 3 deletions(-) | ||
28 | |||
29 | diff --git a/setup.py b/setup.py | ||
30 | index a316038..70aa174 100644 | ||
31 | --- a/setup.py | ||
32 | +++ b/setup.py | ||
33 | @@ -76,8 +76,11 @@ def check_linker_need_libatomic(): | ||
34 | """Test if linker on system needs libatomic.""" | ||
35 | code_test = (b'#include <atomic>\n' + | ||
36 | b'int main() { return std::atomic<int64_t>{}; }') | ||
37 | - cxx = os.environ.get('CXX', 'c++') | ||
38 | - cpp_test = subprocess.Popen([cxx, '-x', 'c++', '-std=c++11', '-'], | ||
39 | + cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++' | ||
40 | + if not cxx_args: | ||
41 | + cxx_args = "-g" | ||
42 | + | ||
43 | + cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++11', '-'], | ||
44 | stdin=PIPE, | ||
45 | stdout=PIPE, | ||
46 | stderr=PIPE) | ||
47 | @@ -87,7 +90,7 @@ def check_linker_need_libatomic(): | ||
48 | # Double-check to see if -latomic actually can solve the problem. | ||
49 | # https://github.com/grpc/grpc/issues/22491 | ||
50 | cpp_test = subprocess.Popen( | ||
51 | - [cxx, '-x', 'c++', '-std=c++11', '-latomic', '-'], | ||
52 | + [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-latomic', '-'], | ||
53 | stdin=PIPE, | ||
54 | stdout=PIPE, | ||
55 | stderr=PIPE) | ||
56 | -- | ||
57 | 2.30.1 | ||
58 | |||
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.14.1.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.14.1.bb deleted file mode 100644 index 2da1a4df03..0000000000 --- a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.14.1.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-grpcio-tools.inc | ||
diff --git a/meta-python/recipes-devtools/python/python-grpcio-tools.inc b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.35.0.bb index 6675f904c1..12b00cfa3f 100644 --- a/meta-python/recipes-devtools/python/python-grpcio-tools.inc +++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.35.0.bb | |||
@@ -2,15 +2,17 @@ DESCRIPTION = "Google gRPC tools" | |||
2 | HOMEPAGE = "http://www.grpc.io/" | 2 | HOMEPAGE = "http://www.grpc.io/" |
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | 4 | ||
5 | DEPENDS_append = " ${PYTHON_PN}-grpcio" | ||
6 | RDEPENDS_${PN} = "${PYTHON_PN}-grpcio" | ||
7 | |||
8 | LICENSE = "Apache-2.0" | 5 | LICENSE = "Apache-2.0" |
9 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" | 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
10 | 7 | ||
11 | inherit pypi | 8 | inherit pypi setuptools3 |
9 | |||
10 | DEPENDS += "${PYTHON_PN}-grpcio" | ||
12 | 11 | ||
13 | SRC_URI[md5sum] = "b2fabfb54c7824c1e49a02de2aa6628e" | 12 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
14 | SRC_URI[sha256sum] = "4ce5aa660d7884f23aac1eafa93b97a4c3e2b512edff871e91fdb6ee86ebd5ea" | 13 | |
14 | SRC_URI[sha256sum] = "9e2a41cba9c5a20ae299d0fdd377fe231434fa04cbfbfb3807293c6ec10b03cf" | ||
15 | |||
16 | RDEPENDS_${PN} = "${PYTHON_PN}-grpcio" | ||
15 | 17 | ||
16 | BBCLASSEXTEND = "native nativesdk" | 18 | BBCLASSEXTEND = "native nativesdk" |