diff options
Diffstat (limited to 'meta-python')
7 files changed, 6 insertions, 94 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc index c6ff160f8c..04abe46d56 100644 --- a/meta-python/recipes-devtools/python/python-lxml.inc +++ b/meta-python/recipes-devtools/python/python-lxml.inc | |||
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \ | |||
18 | 18 | ||
19 | DEPENDS += "libxml2 libxslt" | 19 | DEPENDS += "libxml2 libxslt" |
20 | 20 | ||
21 | SRC_URI[md5sum] = "e54e2fae44d684d6b9c636fe189e93ff" | 21 | SRC_URI[md5sum] = "c30d7e752cc909c1c0c40bd34153443a" |
22 | SRC_URI[sha256sum] = "736f72be15caad8116891eb6aa4a078b590d231fdc63818c40c21624ac71db96" | 22 | SRC_URI[sha256sum] = "f7bc9f702500e205b1560d620f14015fec76dcd6f9e889a946a2ddcc3c344fd0" |
23 | 23 | ||
24 | DISTUTILS_BUILD_ARGS += " \ | 24 | DISTUTILS_BUILD_ARGS += " \ |
25 | --with-xslt-config='pkg-config libxslt' \ | 25 | --with-xslt-config='pkg-config libxslt' \ |
diff --git a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch deleted file mode 100644 index efaecd69c6..0000000000 --- a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From f8d2c3394767025b3b27b71248b3ecb50480cde7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Apr 2017 17:10:45 -0700 | ||
4 | Subject: [PATCH] lxml.etree: Add empty variadic argument | ||
5 | |||
6 | format checker says that argument 4 is a printf formatted argument | ||
7 | but there is no more arguments to follow | ||
8 | |||
9 | Fixes libxslt format warnings | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/lxml/lxml.etree.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c | ||
17 | index d482091..faab06c 100644 | ||
18 | --- a/src/lxml/lxml.etree.c | ||
19 | +++ b/src/lxml/lxml.etree.c | ||
20 | @@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
21 | * except: | ||
22 | */ | ||
23 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error) | ||
24 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
25 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
26 | |||
27 | /* "src/lxml/xsltext.pxi":229 | ||
28 | * c_inst_node.name, _cstr(e)) | ||
29 | @@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
30 | * except: | ||
31 | */ | ||
32 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error) | ||
33 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
34 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
35 | |||
36 | /* "src/lxml/xsltext.pxi":235 | ||
37 | * "Error executing extension element '%s'", c_inst_node.name) | ||
38 | -- | ||
39 | 2.12.2 | ||
40 | |||
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb b/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb deleted file mode 100644 index 5c93a3f841..0000000000 --- a/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | inherit setuptools | ||
2 | require python-lxml.inc | ||
3 | |||
4 | SRC_URI = "${PYPI_SRC_URI} \ | ||
5 | file://0001-lxml.etree-Add-empty-variadic-argument.patch \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb b/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb new file mode 100644 index 0000000000..81ccb12d87 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-lxml.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch deleted file mode 100644 index bb012dc446..0000000000 --- a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 36e64cf2f0676ee422c1fd41456967f3015b2fa3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Apr 2017 17:10:45 -0700 | ||
4 | Subject: [PATCH] lxml.etree: Add empty variadic argument | ||
5 | |||
6 | format checker says that argument 4 is a printf formatted argument | ||
7 | but there is no more arguments to follow | ||
8 | |||
9 | Fixes libxslt format warnings | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/lxml/lxml.etree.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c | ||
17 | index d482091..faab06c 100644 | ||
18 | --- a/src/lxml/lxml.etree.c | ||
19 | +++ b/src/lxml/lxml.etree.c | ||
20 | @@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
21 | * except: | ||
22 | */ | ||
23 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error) | ||
24 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
25 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
26 | |||
27 | /* "src/lxml/xsltext.pxi":229 | ||
28 | * c_inst_node.name, _cstr(e)) | ||
29 | @@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
30 | * except: | ||
31 | */ | ||
32 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error) | ||
33 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
34 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
35 | |||
36 | /* "src/lxml/xsltext.pxi":235 | ||
37 | * "Error executing extension element '%s'", c_inst_node.name) | ||
38 | -- | ||
39 | 2.12.2 | ||
40 | |||
diff --git a/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb b/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb deleted file mode 100644 index 8b13d2dd2c..0000000000 --- a/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-lxml.inc | ||
3 | |||
4 | SRC_URI = "${PYPI_SRC_URI} \ | ||
5 | file://0001-lxml.etree-Add-empty-variadic-argument.patch \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb b/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb new file mode 100644 index 0000000000..ff4bc7faad --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-lxml.inc | ||