diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb | 38 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint_2.12.2.bb | 18 |
2 files changed, 18 insertions, 38 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb deleted file mode 100644 index 60726df09d..0000000000 --- a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | SUMMARY="Pylint is a Python source code analyzer" | ||
2 | HOMEPAGE= "http://www.pylint.org/" | ||
3 | LICENSE = "GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
5 | |||
6 | SRC_URI[md5sum] = "2eb5f3cb8fe567eaf5420dd415012202" | ||
7 | SRC_URI[sha256sum] = "c77311859e0c2d7932095f30d2b1bfdc4b6fe111f534450ba727a52eae330ef2" | ||
8 | |||
9 | inherit pypi setuptools3 python3-dir | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
12 | |||
13 | do_install:append(){ | ||
14 | rm ${D}${bindir}/pylint | ||
15 | cat >> ${D}${bindir}/pylint <<EOF | ||
16 | #!/usr/bin/env ${PYTHON_PN} | ||
17 | from pylint import run_pylint | ||
18 | run_pylint() | ||
19 | EOF | ||
20 | chmod 755 ${D}${bindir}/pylint | ||
21 | sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript | ||
22 | } | ||
23 | |||
24 | PACKAGES =+ "${PN}-tests" | ||
25 | FILES:${PN}-tests+= " \ | ||
26 | ${PYTHON_SITEPACKAGES_DIR}/pylint/test/ \ | ||
27 | ${PYTHON_SITEPACKAGES_DIR}/pylint/testutils.py \ | ||
28 | " | ||
29 | |||
30 | RDEPENDS:${PN} += "${PYTHON_PN}-astroid \ | ||
31 | ${PYTHON_PN}-isort \ | ||
32 | ${PYTHON_PN}-numbers \ | ||
33 | ${PYTHON_PN}-shell \ | ||
34 | ${PYTHON_PN}-json \ | ||
35 | ${PYTHON_PN}-pkgutil \ | ||
36 | ${PYTHON_PN}-difflib \ | ||
37 | ${PYTHON_PN}-netserver \ | ||
38 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.12.2.bb b/meta-python/recipes-devtools/python/python3-pylint_2.12.2.bb new file mode 100644 index 0000000000..6407417d7b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pylint_2.12.2.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY="Pylint is a Python source code analyzer" | ||
2 | HOMEPAGE= "http://www.pylint.org/" | ||
3 | LICENSE = "GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9" | ||
5 | |||
6 | SRC_URI[sha256sum] = "9d945a73640e1fec07ee34b42f5669b770c759acd536ec7b16d7e4b87a9c9ff9" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | RDEPENDS:${PN} += "${PYTHON_PN}-astroid \ | ||
11 | ${PYTHON_PN}-isort \ | ||
12 | ${PYTHON_PN}-numbers \ | ||
13 | ${PYTHON_PN}-shell \ | ||
14 | ${PYTHON_PN}-json \ | ||
15 | ${PYTHON_PN}-pkgutil \ | ||
16 | ${PYTHON_PN}-difflib \ | ||
17 | ${PYTHON_PN}-netserver \ | ||
18 | " | ||