summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pdm-backend_2.4.3.bb14
-rw-r--r--meta-python/recipes-devtools/python/python3-pdm-build-locked_0.3.5.bb14
-rw-r--r--meta-python/recipes-devtools/python/python3-pdm_2.23.0.bb16
3 files changed, 0 insertions, 44 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pdm-backend_2.4.3.bb b/meta-python/recipes-devtools/python/python3-pdm-backend_2.4.3.bb
deleted file mode 100644
index 46440c9d5d..0000000000
--- a/meta-python/recipes-devtools/python/python3-pdm-backend_2.4.3.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "The build backend used by PDM that supports latest packaging standards"
2HOMEPAGE = "https://github.com/pdm-project/pdm-backend"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a564297b3c5b629a528b92fd8ff61ea"
6
7SRC_URI[sha256sum] = "dbd9047a7ac10d11a5227e97163b617ad5d665050476ff63867d971758200728"
8
9inherit pypi python_setuptools_build_meta
10
11PYPI_PACKAGE = "pdm_backend"
12UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pdm-build-locked_0.3.5.bb b/meta-python/recipes-devtools/python/python3-pdm-build-locked_0.3.5.bb
deleted file mode 100644
index c0eee4e97d..0000000000
--- a/meta-python/recipes-devtools/python/python3-pdm-build-locked_0.3.5.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "pdm plugin to publish locked dependencies as optional-dependencies"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=19382cdf9c143df4f00b9caa0b60c75a"
4
5SRC_URI[sha256sum] = "ab2f381e00d79841d46be2e6909c265038b9fa951de2bf551ca6adb7f6844201"
6
7inherit pypi python_setuptools_build_meta
8
9DEPENDS += " python3-pdm-backend-native"
10
11PYPI_PACKAGE = "pdm_build_locked"
12UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
13
14BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pdm_2.23.0.bb b/meta-python/recipes-devtools/python/python3-pdm_2.23.0.bb
deleted file mode 100644
index f565819a9a..0000000000
--- a/meta-python/recipes-devtools/python/python3-pdm_2.23.0.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "A modern Python package and dependency manager supporting the latest PEP standards"
2HOMEPAGE = "https://pdm-project.org/latest/"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2eb31a2cc1a758c34b499f287dd04ef2"
6
7SRC_URI[sha256sum] = "ec5ce439648b42b928f4afa91c2b6251e6a33f40cc83779d899ca970bd9eb131"
8
9inherit pypi python_setuptools_build_meta
10
11DEPENDS += " \
12 python3-pdm-backend-native \
13 python3-pdm-build-locked-native \
14"
15
16BBCLASSEXTEND = "native nativesdk"