diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch | 30 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb) | 6 |
2 files changed, 34 insertions, 2 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch new file mode 100644 index 0000000000..c88912bfa0 --- /dev/null +++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 54014061be2fed20d6c35aba9719ea70a9fea9ea Mon Sep 17 00:00:00 2001 | ||
2 | From: Vojtech Trefny <vtrefny@redhat.com> | ||
3 | Date: Wed, 1 Sep 2021 08:59:19 +0200 | ||
4 | Subject: [PATCH] Use setuptools instead of distutils in setup.py | ||
5 | |||
6 | The distutils module is deprecated and will be removed in Python | ||
7 | 3.12. | ||
8 | |||
9 | Upstream-Status: Backport [https://github.com/kraj/blivet-gui/commit/54014061be2fed20d6c35aba9719ea70a9fea9ea] | ||
10 | --- | ||
11 | setup.py | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index aa8ef57..77849a1 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -1,7 +1,7 @@ | ||
19 | from __future__ import print_function | ||
20 | |||
21 | -from distutils.core import setup | ||
22 | -from distutils.command.sdist import sdist | ||
23 | +from setuptools import setup | ||
24 | +from setuptools.command.sdist import sdist | ||
25 | import glob | ||
26 | import sys | ||
27 | |||
28 | -- | ||
29 | 2.35.1 | ||
30 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb index 632b313a86..9522770eff 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.2.1.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb | |||
@@ -8,8 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
8 | S = "${WORKDIR}/git" | 8 | S = "${WORKDIR}/git" |
9 | B = "${S}" | 9 | B = "${S}" |
10 | 10 | ||
11 | SRCREV = "adb6bd69fb3cfa709265db66ddcee04c0b5e070f" | 11 | SRCREV = "42512ee48494cee71febf04078d9774f0146a085" |
12 | SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https" | 12 | SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \ |
13 | file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \ | ||
14 | " | ||
13 | 15 | ||
14 | inherit features_check | 16 | inherit features_check |
15 | REQUIRED_DISTRO_FEATURES = "x11 systemd" | 17 | REQUIRED_DISTRO_FEATURES = "x11 systemd" |