summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-gpsd-py3_0.3.0.bb16
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index c1271d09dc..4512f839f4 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -144,6 +144,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
144 python3-gmqtt \ 144 python3-gmqtt \
145 python3-gnupg \ 145 python3-gnupg \
146 python3-google-api-python-client \ 146 python3-google-api-python-client \
147 python3-gpsd-py3 \
147 python3-graphviz \ 148 python3-graphviz \
148 python3-greenlet \ 149 python3-greenlet \
149 python3-greenstalk \ 150 python3-greenstalk \
diff --git a/meta-python/recipes-devtools/python/python3-gpsd-py3_0.3.0.bb b/meta-python/recipes-devtools/python/python3-gpsd-py3_0.3.0.bb
new file mode 100644
index 0000000000..35485ba7c4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gpsd-py3_0.3.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "This is a library for polling gpsd in Python3"
2HOMEPAGE = "https://github.com/MartijnBraam/gpsd-py3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://setup.py;beginline=10;endline=10;md5=c2d9994c57f0444e39f1dab19af50254"
5SRC_URI[md5sum] = "041ce56e8879e2104b4d54c8119cd529"
6SRC_URI[sha256sum] = "2908d3bd78dfb6720ecfe22f97e139b5a4a198f38df3a77215cf644a33513192"
7
8PYPI_PACKAGE = "gpsd-py3"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS_${PN} += " \
15 python3 \
16"