summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo.inc29
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb31
2 files changed, 30 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymongo.inc b/meta-python/recipes-devtools/python/python-pymongo.inc
deleted file mode 100644
index 2b9794f9c4..0000000000
--- a/meta-python/recipes-devtools/python/python-pymongo.inc
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11SRC_URI[md5sum] = "e31b9c0190c9eaf1f792d0277b2a8ebe"
12SRC_URI[sha256sum] = "993257f6ca3cde55332af1f62af3e04ca89ce63c08b56a387cdd46136c72f2fa"
13
14PACKAGES =+ "${PYTHON_PN}-bson"
15
16FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
17
18RDEPENDS_${PYTHON_PN}-bson += " \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-netclient \
22 ${PYTHON_PN}-numbers \
23 ${PYTHON_PN}-threading \
24"
25
26RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-bson \
28 ${PYTHON_PN}-pprint \
29"
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb
index 5164b186bf..f69ca53cf5 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb
@@ -1,2 +1,31 @@
1SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11SRC_URI[md5sum] = "e31b9c0190c9eaf1f792d0277b2a8ebe"
12SRC_URI[sha256sum] = "993257f6ca3cde55332af1f62af3e04ca89ce63c08b56a387cdd46136c72f2fa"
13
1inherit pypi setuptools3 14inherit pypi setuptools3
2require python-pymongo.inc 15
16PACKAGES =+ "${PYTHON_PN}-bson"
17
18FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
19
20RDEPENDS_${PYTHON_PN}-bson += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-netclient \
24 ${PYTHON_PN}-numbers \
25 ${PYTHON_PN}-threading \
26"
27
28RDEPENDS_${PN} += " \
29 ${PYTHON_PN}-bson \
30 ${PYTHON_PN}-pprint \
31"