diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-xlrd/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb | 1 |
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd/run-ptest b/meta-python/recipes-devtools/python/python3-xlrd/run-ptest index 3385d68939..8d2017d39c 100644 --- a/meta-python/recipes-devtools/python/python3-xlrd/run-ptest +++ b/meta-python/recipes-devtools/python/python3-xlrd/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb index 5e63d3c307..8a9af14d3e 100644 --- a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb +++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb | |||
@@ -30,6 +30,7 @@ RDEPENDS:${PN} += " \ | |||
30 | 30 | ||
31 | RDEPENDS:${PN}-ptest += " \ | 31 | RDEPENDS:${PN}-ptest += " \ |
32 | python3-pytest \ | 32 | python3-pytest \ |
33 | python3-unittest-automake-output \ | ||
33 | " | 34 | " |
34 | 35 | ||
35 | do_install_ptest() { | 36 | do_install_ptest() { |