diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pykwalify/0001-rule.py-fix-missing-comma.patch | 34 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb | 2 |
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pykwalify/0001-rule.py-fix-missing-comma.patch b/meta-python/recipes-devtools/python/python3-pykwalify/0001-rule.py-fix-missing-comma.patch new file mode 100644 index 0000000000..689355eeaf --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pykwalify/0001-rule.py-fix-missing-comma.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From f96b76efb810d7d559254d0ec58de628e09f525a Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Mart=C3=AD=20Bol=C3=ADvar?= <marti.f.bolivar@gmail.com> | ||
3 | Date: Mon, 13 Jan 2020 08:42:05 -0800 | ||
4 | Subject: [PATCH] rule.py: fix missing comma | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | A line in the defined_keywords list is missing a comma. Add it. | ||
10 | |||
11 | Signed-off-by: Martí Bolívar <marti.f.bolivar@gmail.com> | ||
12 | |||
13 | Upstream-Status: Backport [https://github.com/Grokzen/pykwalify.git] | ||
14 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
15 | --- | ||
16 | pykwalify/rule.py | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/pykwalify/rule.py b/pykwalify/rule.py | ||
20 | index 7ac2c9e..f044b69 100644 | ||
21 | --- a/pykwalify/rule.py | ||
22 | +++ b/pykwalify/rule.py | ||
23 | @@ -340,7 +340,7 @@ class Rule(object): | ||
24 | ('matching', 'matching'), | ||
25 | ('matching_rule', 'matching_rule'), | ||
26 | ('name', 'name'), | ||
27 | - ('nullable', 'nullable') | ||
28 | + ('nullable', 'nullable'), | ||
29 | ('parent', 'parent'), | ||
30 | ('pattern', 'pattern'), | ||
31 | ('pattern_regexp', 'pattern_regexp'), | ||
32 | -- | ||
33 | 2.18.2 | ||
34 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb b/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb index 4440723d3a..770503f50b 100644 --- a/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb +++ b/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb | |||
@@ -7,6 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a72ea5159364a2cd7f45c6dcbee37872" | |||
7 | SRC_URI[md5sum] = "58357f1d0f77de976e73dbd3660af75b" | 7 | SRC_URI[md5sum] = "58357f1d0f77de976e73dbd3660af75b" |
8 | SRC_URI[sha256sum] = "7e8b39c5a3a10bc176682b3bd9a7422c39ca247482df198b402e8015defcceb2" | 8 | SRC_URI[sha256sum] = "7e8b39c5a3a10bc176682b3bd9a7422c39ca247482df198b402e8015defcceb2" |
9 | 9 | ||
10 | SRC_URI += "file://0001-rule.py-fix-missing-comma.patch" | ||
11 | |||
10 | PYPI_PACKAGE = "pykwalify" | 12 | PYPI_PACKAGE = "pykwalify" |
11 | inherit setuptools3 pypi | 13 | inherit setuptools3 pypi |
12 | unset _PYTHON_SYSCONFIGDATA_NAME | 14 | unset _PYTHON_SYSCONFIGDATA_NAME |