summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pyyaml-include_2.2.bb10
2 files changed, 1 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
deleted file mode 100755
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include_2.2.bb b/meta-python/recipes-devtools/python/python3-pyyaml-include_2.2.bb
index a93a2391dc..49e643c710 100644
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include_2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include_2.2.bb
@@ -7,17 +7,11 @@ SRCREV = "c5be2b7dfc4aaa91e44dbeb6fa42adc80936ef9d"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/tanbro/pyyaml-include;protocol=https;branch=main \ 9 git://github.com/tanbro/pyyaml-include;protocol=https;branch=main \
10 file://run-ptest \
11 " 10 "
12 11
13S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
14 13
15inherit python_setuptools_build_meta ptest 14inherit python_setuptools_build_meta ptest-python-pytest
16
17do_install_ptest() {
18 install -d ${D}${PTEST_PATH}/tests
19 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
20}
21 15
22RDEPENDS:${PN} += " \ 16RDEPENDS:${PN} += " \
23 python3-pyyaml \ 17 python3-pyyaml \
@@ -27,7 +21,5 @@ RDEPENDS:${PN}-ptest += " \
27 python3-fsspec \ 21 python3-fsspec \
28 python3-aiohttp \ 22 python3-aiohttp \
29 python3-requests \ 23 python3-requests \
30 python3-pytest \
31 python3-unittest-automake-output \
32" 24"
33BBCLASSEXTEND = "native nativesdk" 25BBCLASSEXTEND = "native nativesdk"