summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch13
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.10.2.bb (renamed from meta-python/recipes-devtools/python/python3-icu_2.8.1.bb)2
2 files changed, 9 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
index 36485d56ce..7bb5ee58cc 100644
--- a/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
+++ b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
@@ -10,25 +10,25 @@ Also, don't use icu-config
10Upstream-Status: Inappropriate [OE specific] 10Upstream-Status: Inappropriate [OE specific]
11Signed-off-by: Armin Kuster <akuster808@gmail.com> 11Signed-off-by: Armin Kuster <akuster808@gmail.com>
12Signed-off-by: Khem Raj <raj.khem@gmail.com> 12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13 13Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
14--- 14---
15 setup.py | 3 +-- 15 setup.py | 3 +--
16 1 file changed, 1 insertion(+), 2 deletions(-) 16 1 file changed, 1 insertion(+), 2 deletions(-)
17 17
18diff --git a/setup.py b/setup.py 18diff --git a/setup.py b/setup.py
19index d308b80..56e9c74 100644 19index 176c9ab..0a10268 100644
20--- a/setup.py 20--- a/setup.py
21+++ b/setup.py 21+++ b/setup.py
22@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU major version supported: %s) 22@@ -68,7 +68,7 @@ elif platform.startswith('freebsd'):
23 23
24 CONFIGURE_WITH_ICU_CONFIG = { 24 CONFIGURE_WITH_ICU_CONFIG = {
25 'darwin': True, 25 'darwin': False,
26- 'linux': True, 26- 'linux': True,
27+ 'linux': False, 27+ 'linux': False,
28 'freebsd': False, # not tested 28 'freebsd': False, # not tested
29 'win32': False, # no icu-config 29 'win32': False, # no icu-config
30 'sunos5': False, # not tested 30 'sunos5': False, # not tested
31@@ -273,7 +273,6 @@ setup(name="PyICU", 31@@ -277,7 +277,6 @@ setup(name="PyICU",
32 ext_modules=[Extension('icu._icu_', 32 ext_modules=[Extension('icu._icu_',
33 [filename for filename in sorted(os.listdir(os.curdir)) 33 [filename for filename in sorted(os.listdir(os.curdir))
34 if filename.endswith('.cpp')], 34 if filename.endswith('.cpp')],
@@ -36,3 +36,6 @@ index d308b80..56e9c74 100644
36 extra_compile_args=_cflags, 36 extra_compile_args=_cflags,
37 extra_link_args=_lflags, 37 extra_link_args=_lflags,
38 libraries=_libraries)], 38 libraries=_libraries)],
39--
402.34.1
41
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.8.1.bb b/meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
index 027ef129ee..cbcc2f87b6 100644
--- a/meta-python/recipes-devtools/python/python3-icu_2.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0724597863f1581ab01429e0423e779f"
8DEPENDS += "icu" 8DEPENDS += "icu"
9 9
10PYPI_PACKAGE = "PyICU" 10PYPI_PACKAGE = "PyICU"
11SRC_URI[sha256sum] = "f0b9549a87f87ba7c413f13679d137271e0b37f1f39b0109ace38257d4d148d6" 11SRC_URI[sha256sum] = "0c3309eea7fab6857507ace62403515b60fe096cbfb4f90d14f55ff75c5441c1"
12 12
13SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch" 13SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"
14 14