diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-simpleeval/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb | 11 |
2 files changed, 2 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest b/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb b/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb index 4537645c73..b4dc82bfb3 100644 --- a/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb +++ b/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb | |||
@@ -5,21 +5,14 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=83843c8f0f3beb18af2f282faecbdebe" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "67bbf246040ac3b57c29cf048657b9cf31d4e7b9d6659684daa08ca8f1e45829" | 6 | SRC_URI[sha256sum] = "67bbf246040ac3b57c29cf048657b9cf31d4e7b9d6659684daa08ca8f1e45829" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta python_hatchling ptest | 8 | inherit pypi python_setuptools_build_meta python_hatchling ptest-python-pytest |
9 | 9 | ||
10 | BBCLASSEXTEND = "native nativesdk" | 10 | BBCLASSEXTEND = "native nativesdk" |
11 | 11 | ||
12 | SRC_URI += "file://run-ptest" | ||
13 | |||
14 | RDEPENDS:${PN} += " \ | 12 | RDEPENDS:${PN} += " \ |
15 | python3-math \ | 13 | python3-math \ |
16 | " | 14 | " |
17 | 15 | ||
18 | RDEPENDS:${PN}-ptest += " \ | 16 | do_install_ptest:append() { |
19 | python3-pytest \ | ||
20 | python3-unittest-automake-output \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/ | 17 | cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/ |
25 | } | 18 | } |