diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-packaging.inc | 10 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-packaging_20.3.bb | 12 |
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-packaging.inc b/meta-python/recipes-devtools/python/python-packaging.inc deleted file mode 100644 index 418483f4e8..0000000000 --- a/meta-python/recipes-devtools/python/python-packaging.inc +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | DESCRIPTION = "Core utilities for Python packages" | ||
2 | HOMEPAGE = "https://github.com/pypa/packaging" | ||
3 | LICENSE = "Apache-2.0 & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" | ||
5 | |||
6 | SRC_URI[md5sum] = "19e0d1f82a9007b448650ccfeffd0a26" | ||
7 | SRC_URI[sha256sum] = "3c292b474fda1671ec57d46d739d072bfd495a4f51ad01a055121d81e952b7a3" | ||
8 | |||
9 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
10 | RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing" | ||
diff --git a/meta-python/recipes-devtools/python/python3-packaging_20.3.bb b/meta-python/recipes-devtools/python/python3-packaging_20.3.bb index aa20fb26f9..9eee84b1b2 100644 --- a/meta-python/recipes-devtools/python/python3-packaging_20.3.bb +++ b/meta-python/recipes-devtools/python/python3-packaging_20.3.bb | |||
@@ -1,2 +1,12 @@ | |||
1 | DESCRIPTION = "Core utilities for Python packages" | ||
2 | HOMEPAGE = "https://github.com/pypa/packaging" | ||
3 | LICENSE = "Apache-2.0 & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" | ||
5 | |||
6 | SRC_URI[md5sum] = "19e0d1f82a9007b448650ccfeffd0a26" | ||
7 | SRC_URI[sha256sum] = "3c292b474fda1671ec57d46d739d072bfd495a4f51ad01a055121d81e952b7a3" | ||
8 | |||
1 | inherit pypi setuptools3 | 9 | inherit pypi setuptools3 |
2 | require python-packaging.inc | 10 | |
11 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
12 | RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing" | ||