diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-test-generator/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb | 16 |
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-test-generator/run-ptest b/meta-python/recipes-devtools/python/python3-test-generator/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-test-generator/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb b/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb index 14943a4bd5..a83ee5efc2 100644 --- a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb +++ b/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb | |||
@@ -5,10 +5,24 @@ parsers that prevent any potentially malicious operation." | |||
5 | LICENSE = "ISC" | 5 | LICENSE = "ISC" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00" |
7 | 7 | ||
8 | SRC_URI += " \ | ||
9 | file://run-ptest \ | ||
10 | " | ||
11 | |||
8 | SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1" | 12 | SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1" |
9 | SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a" | 13 | SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a" |
10 | 14 | ||
11 | inherit pypi setuptools3 | 15 | inherit pypi setuptools3 ptest |
16 | |||
17 | RDEPENDS_${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | ${PYTHON_PN}-mock \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/tests | ||
24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
25 | } | ||
12 | 26 | ||
13 | DEPENDS += "python3-nose-native" | 27 | DEPENDS += "python3-nose-native" |
14 | 28 | ||