summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-parse.inc26
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.15.0.bb28
2 files changed, 26 insertions, 28 deletions
diff --git a/meta-python/recipes-devtools/python/python-parse.inc b/meta-python/recipes-devtools/python/python-parse.inc
deleted file mode 100644
index ecfd67172a..0000000000
--- a/meta-python/recipes-devtools/python/python-parse.inc
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://parse.py;beginline=1325;endline=1345;md5=3d987b2e73881bbce768a80f9cdd23d9"
5
6SRC_URI[md5sum] = "a5aa82b2b8b4d733d227e3c99d7d01b4"
7SRC_URI[sha256sum] = "a6d4e2c2f1fbde6717d28084a191a052950f758c0cbd83805357e6575c2b95c0"
8
9inherit pypi ptest
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 "
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
26}
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.15.0.bb b/meta-python/recipes-devtools/python/python3-parse_1.15.0.bb
index b1242545cc..bff41449c2 100644
--- a/meta-python/recipes-devtools/python/python3-parse_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python3-parse_1.15.0.bb
@@ -1,2 +1,26 @@
1inherit setuptools3 1SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2require python-parse.inc 2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://parse.py;beginline=1325;endline=1345;md5=3d987b2e73881bbce768a80f9cdd23d9"
5
6SRC_URI[md5sum] = "a5aa82b2b8b4d733d227e3c99d7d01b4"
7SRC_URI[sha256sum] = "a6d4e2c2f1fbde6717d28084a191a052950f758c0cbd83805357e6575c2b95c0"
8
9inherit pypi setuptools3 ptest
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 "
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
26}