summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb14
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb15
2 files changed, 15 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
deleted file mode 100644
index 52d109abc8..0000000000
--- a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581"
4
5SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae"
6SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-ctypes \
12"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
new file mode 100644
index 0000000000..8f331529a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2HOMEPAGE = "https://github.com/asweigart/pyperclip"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=d7dd4b0d1f7153322a546e89b5a0a632"
5
6SRC_URI[md5sum] = "c2564a74b909b6fc32401afd619de83d"
7SRC_URI[sha256sum] = "b75b975160428d84608c26edba2dec146e7799566aea42c1fe1b32e72b6028f2"
8
9inherit pypi setuptools3
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-ctypes \
13"
14
15BBCLASSEXTEND = "native nativesdk"