diff options
Diffstat (limited to 'meta-python')
3 files changed, 14 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto.inc b/meta-python/recipes-devtools/python/python-pycrypto.inc index fb2c17df1f..232cdb7116 100644 --- a/meta-python/recipes-devtools/python/python-pycrypto.inc +++ b/meta-python/recipes-devtools/python/python-pycrypto.inc | |||
@@ -3,12 +3,16 @@ HOMEPAGE = "http://www.pycrypto.org/" | |||
3 | LICENSE = "PSFv2" | 3 | LICENSE = "PSFv2" |
4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d" | 4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d" |
5 | 5 | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pycrypto:" |
7 | 7 | ||
8 | DEPENDS += " gmp" | 8 | DEPENDS += " gmp" |
9 | 9 | ||
10 | inherit pypi autotools-brokensep | 10 | inherit pypi autotools-brokensep |
11 | 11 | ||
12 | SRC_URI += "file://cross-compiling.patch \ | ||
13 | file://CVE-2013-7459.patch \ | ||
14 | " | ||
15 | |||
12 | SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda" | 16 | SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda" |
13 | SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c" | 17 | SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c" |
14 | 18 | ||
diff --git a/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb index 919f91ecb1..e13db01b7f 100644 --- a/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb +++ b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb | |||
@@ -1,10 +1,6 @@ | |||
1 | inherit distutils | 1 | inherit distutils |
2 | require python-pycrypto.inc | 2 | require python-pycrypto.inc |
3 | 3 | ||
4 | SRC_URI += "file://cross-compiling.patch \ | ||
5 | file://CVE-2013-7459.patch \ | ||
6 | " | ||
7 | |||
8 | # We explicitly call distutils_do_install, since we want it to run, but | 4 | # We explicitly call distutils_do_install, since we want it to run, but |
9 | # *don't* want the autotools install to run, since this package doesn't | 5 | # *don't* want the autotools install to run, since this package doesn't |
10 | # provide a "make install" target. | 6 | # provide a "make install" target. |
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb new file mode 100644 index 0000000000..02d634cb00 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | inherit distutils3 | ||
2 | require python-pycrypto.inc | ||
3 | |||
4 | # We explicitly call distutils_do_install, since we want it to run, but | ||
5 | # *don't* want the autotools install to run, since this package doesn't | ||
6 | # provide a "make install" target. | ||
7 | do_install() { | ||
8 | distutils3_do_install | ||
9 | } | ||