diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc | 19 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb | 21 |
2 files changed, 19 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc deleted file mode 100644 index bce44a28b4..0000000000 --- a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | SUMMARY = "Backport of functools.lru_cache from Python 3.3" | ||
2 | HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=57;endline=57;md5=98fc3658e5970d26f6b2109808c766be" | ||
6 | |||
7 | PYPI_PACKAGE = "backports.functools_lru_cache" | ||
8 | |||
9 | SRC_URI[md5sum] = "20f53f54cd3f04b3346ce75a54959754" | ||
10 | SRC_URI[sha256sum] = "9d98697f088eb1b0fa451391f91afb5e3ebde16bbdb272819fd091151fda4f1a" | ||
11 | |||
12 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
13 | |||
14 | inherit pypi | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-pickle \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb index 91fcc41fc7..9182792baf 100644 --- a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb +++ b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb | |||
@@ -1,2 +1,19 @@ | |||
1 | require python-backports-functools-lru-cache.inc | 1 | SUMMARY = "Backport of functools.lru_cache from Python 3.3" |
2 | inherit setuptools3 | 2 | HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache" |
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=57;endline=57;md5=98fc3658e5970d26f6b2109808c766be" | ||
6 | |||
7 | PYPI_PACKAGE = "backports.functools_lru_cache" | ||
8 | |||
9 | SRC_URI[md5sum] = "20f53f54cd3f04b3346ce75a54959754" | ||
10 | SRC_URI[sha256sum] = "9d98697f088eb1b0fa451391f91afb5e3ebde16bbdb272819fd091151fda4f1a" | ||
11 | |||
12 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
13 | |||
14 | inherit pypi setuptools3 | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-pickle \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||