summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch27
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzstd_0.16.2.bb3
3 files changed, 30 insertions, 1 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 58f53dedc7..bdb4482dc5 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -70,6 +70,7 @@ PTESTS_FAST_META_PYTHON = "\
70 python3-pytoml \ 70 python3-pytoml \
71 python3-pyyaml-include \ 71 python3-pyyaml-include \
72 python3-pydbus \ 72 python3-pydbus \
73 python3-pyzstd \
73 python3-rapidjson \ 74 python3-rapidjson \
74 python3-requests-file \ 75 python3-requests-file \
75 python3-requests-toolbelt \ 76 python3-requests-toolbelt \
diff --git a/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch b/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch
new file mode 100644
index 0000000000..8fc26bd90b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyzstd/0001-Bump-setuptools-dependency-from-74-to-79.patch
@@ -0,0 +1,27 @@
1From e648bb2439cad0d2ce47875edc7944d0b446fdb4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 9 Apr 2025 14:38:31 -0700
4Subject: [PATCH] Bump setuptools dependency from 74 to 79
5
6Upstream sticks to 0.74 since setuptools have dropped msvc9compiler
7support beyond that which is needed for python 3.9 on windows. We
8do not have this problem on Linux
9
10Upstream-Status: Inappropriate [OE-specific]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 pyproject.toml | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/pyproject.toml b/pyproject.toml
17index dd885e4..9f273b3 100644
18--- a/pyproject.toml
19+++ b/pyproject.toml
20@@ -1,6 +1,6 @@
21 [build-system]
22 # setuptools 64+ support --build-option
23 # setuptools 74+ drops distutils.msvc9compiler required for Python 3.9 under Windows
24-requires = ["setuptools>=64,<74"]
25+requires = ["setuptools>=64,<79"]
26 backend-path = ["build_script"]
27 build-backend = "pyzstd_pep517"
diff --git a/meta-python/recipes-devtools/python/python3-pyzstd_0.16.2.bb b/meta-python/recipes-devtools/python/python3-pyzstd_0.16.2.bb
index c1abd59f60..e1c24404e8 100644
--- a/meta-python/recipes-devtools/python/python3-pyzstd_0.16.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzstd_0.16.2.bb
@@ -8,9 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=aedb5a2679cd1552fb61c181ef974b9e"
8 8
9PYPI_PACKAGE = "pyzstd" 9PYPI_PACKAGE = "pyzstd"
10 10
11SRC_URI += "file://0001-Bump-setuptools-dependency-from-74-to-79.patch"
11SRC_URI[sha256sum] = "179c1a2ea1565abf09c5f2fd72f9ce7c54b2764cf7369e05c0bfd8f1f67f63d2" 12SRC_URI[sha256sum] = "179c1a2ea1565abf09c5f2fd72f9ce7c54b2764cf7369e05c0bfd8f1f67f63d2"
12 13
13inherit pypi setuptools3 14inherit pypi python_setuptools_build_meta ptest-python-pytest
14 15
15# clang-16 with -flto segfaults on arm, therefore ignore flto for now 16# clang-16 with -flto segfaults on arm, therefore ignore flto for now
16do_configure:append:arm:toolchain-clang() { 17do_configure:append:arm:toolchain-clang() {