diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-execnet/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-execnet_2.1.1.bb | 14 |
2 files changed, 2 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-execnet/run-ptest b/meta-python/recipes-devtools/python/python3-execnet/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-execnet/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-execnet_2.1.1.bb b/meta-python/recipes-devtools/python/python3-execnet_2.1.1.bb index 94c1a228e3..54c102bec7 100644 --- a/meta-python/recipes-devtools/python/python3-execnet_2.1.1.bb +++ b/meta-python/recipes-devtools/python/python3-execnet_2.1.1.bb | |||
@@ -11,21 +11,11 @@ DEPENDS += "\ | |||
11 | python3-hatch-vcs-native \ | 11 | python3-hatch-vcs-native \ |
12 | " | 12 | " |
13 | 13 | ||
14 | SRC_URI += "file://run-ptest \ | ||
15 | " | ||
16 | SRC_URI[sha256sum] = "5189b52c6121c24feae288166ab41b32549c7e2348652736540b9e6e7d4e72e3" | 14 | SRC_URI[sha256sum] = "5189b52c6121c24feae288166ab41b32549c7e2348652736540b9e6e7d4e72e3" |
17 | 15 | ||
18 | inherit ptest pypi python_hatchling | 16 | inherit ptest-python-pytest pypi python_hatchling |
19 | 17 | ||
20 | do_install_ptest() { | 18 | PTEST_PYTEST_DIR = "testing" |
21 | install -d ${D}${PTEST_PATH}/tests | ||
22 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/ | ||
23 | } | ||
24 | |||
25 | RDEPENDS:${PN}-ptest += "\ | ||
26 | python3-pytest \ | ||
27 | python3-unittest-automake-output \ | ||
28 | " | ||
29 | 19 | ||
30 | RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" | 20 | RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" |
31 | 21 | ||