diff options
Diffstat (limited to 'meta-python')
3 files changed, 13 insertions, 39 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch deleted file mode 100644 index ed6ceca8e1..0000000000 --- a/meta-python/recipes-devtools/python/python3-configobj/0001-Switch-from-using-distutils-to-setuptools.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From ad9024e50a9df4a2b8a1a019e07bb133c3df31bf Mon Sep 17 00:00:00 2001 | ||
2 | From: Daniel Watkins <daniel@daniel-watkins.co.uk> | ||
3 | Date: Thu, 28 Aug 2014 18:49:04 +0200 | ||
4 | Subject: [PATCH] Switch from using distutils to setuptools. | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | |||
8 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
9 | --- | ||
10 | setup.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/setup.py b/setup.py | ||
14 | index c6d57a6..6755ab4 100644 | ||
15 | --- a/setup.py | ||
16 | +++ b/setup.py | ||
17 | @@ -12,7 +12,7 @@ | ||
18 | # http://opensource.org/licenses/BSD-3-Clause | ||
19 | import os | ||
20 | import sys | ||
21 | -from distutils.core import setup | ||
22 | +from setuptools import setup | ||
23 | # a simple import wouldn't work if we moved towards a package with __init__ | ||
24 | from _version import __version__ | ||
25 | |||
26 | -- | ||
27 | 2.30.2 | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb b/meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb deleted file mode 100644 index 1125a6389d..0000000000 --- a/meta-python/recipes-devtools/python/python3-configobj_5.0.6.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | SUMMARY = "Config file reading, writing and validation." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://configobj.py;md5=a7c3968dd866dfd23e91e125b669ab21" | ||
5 | |||
6 | PYPI_PACKAGE = "configobj" | ||
7 | SRC_URI[sha256sum] = "a2f5650770e1c87fb335af19a9b7eb73fc05ccf22144eb68db7d00cd2bcb0902" | ||
8 | |||
9 | SRC_URI += "file://0001-Switch-from-using-distutils-to-setuptools.patch" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
diff --git a/meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb b/meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb new file mode 100644 index 0000000000..b8b5e6f897 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-configobj_5.0.8.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "Config file reading, writing and validation." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3d6f99b84d9a94610c62e48fa2e59e72" | ||
5 | |||
6 | PYPI_PACKAGE = "configobj" | ||
7 | SRC_URI[sha256sum] = "6f704434a07dc4f4dc7c9a745172c1cad449feb548febd9f7fe362629c627a97" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS:${PN} += "\ | ||
12 | ${PYTHON_PN}-six \ | ||
13 | " | ||