diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ordered-set/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb | 16 |
2 files changed, 3 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest deleted file mode 100644 index 64799ba008..0000000000 --- a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake test_ordered_set.py | ||
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb index 64637b858d..2d6b6ca06c 100644 --- a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb | |||
@@ -5,19 +5,9 @@ LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=3bf5e1ad64c0d99032c3143361fa234e" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "694a8e44c87657c59292ede72891eb91d34131f6531463aab3009191c77364a8" | 6 | SRC_URI[sha256sum] = "694a8e44c87657c59292ede72891eb91d34131f6531463aab3009191c77364a8" |
7 | 7 | ||
8 | inherit pypi python_flit_core ptest | 8 | inherit pypi python_flit_core ptest-python-pytest |
9 | 9 | ||
10 | DEPENDS += "python3-pytest-runner-native" | 10 | PTEST_PYTEST_DIR = "test" |
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | 11 | ||
16 | RDEPENDS:${PN}-ptest += " \ | 12 | DEPENDS += "python3-pytest-runner-native" |
17 | python3-pytest \ | ||
18 | python3-unittest-automake-output \ | ||
19 | " | ||
20 | 13 | ||
21 | do_install_ptest() { | ||
22 | cp -f ${S}/test/test_ordered_set.py ${D}${PTEST_PATH}/ | ||
23 | } | ||