summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch29
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb58
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_26.3.0.bb60
3 files changed, 60 insertions, 87 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch
deleted file mode 100644
index 61aeaca5fa..0000000000
--- a/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From efae4e08d13e0958d929ea524e21c0a210b31982 Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Fri, 22 Jan 2021 11:41:12 +0200
4Subject: [PATCH] setup.py: Adjust _add_rpath
5
6Fix error: unrecognized command-line option '-R'
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
11
12---
13 setup.py | 3 ---
14 1 file changed, 3 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index b634d94..7f6a2f1 100755
18--- a/setup.py
19+++ b/setup.py
20@@ -235,9 +235,6 @@ def _add_rpath(settings, path):
21 """
22 if sys.platform == 'darwin':
23 settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path])
24- else:
25- settings['runtime_library_dirs'].append(path)
26-
27
28 def settings_from_prefix(prefix=None):
29 """load appropriate library/include settings from ZMQ prefix"""
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
deleted file mode 100644
index 39b754dd5d..0000000000
--- a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1SUMMARY = "PyZMQ: Python bindings for ZMQ"
2DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
3HOMEPAGE = "https://zeromq.org/bindings:python"
4LICENSE = "BSD-3-Clause & LGPL-3.0-only"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.BSD;md5=1787206f198344195a671b60326c59dc \
7 file://LICENSE.LESSER;md5=0e99bfbdd8b9d33b0221986fe3be89ed \
8"
9
10DEPENDS = "python3-packaging-native python3-setuptools-scm-native zeromq"
11
12SRC_URI:append = " \
13 file://club-rpath-out.patch \
14 file://run-ptest \
15"
16SRC_URI[sha256sum] = "93f1aa311e8bb912e34f004cf186407a4e90eec4f0ecc0efd26056bf7eda0226"
17
18inherit pypi pkgconfig python_setuptools_build_meta ptest cython
19
20PACKAGES =+ "\
21 ${PN}-test \
22"
23
24FILES:${PN}-test += "\
25 ${PYTHON_SITEPACKAGES_DIR}/*/tests \
26"
27
28RDEPENDS:${PN} += "\
29 python3-json \
30 python3-multiprocessing \
31 python3-tornado \
32"
33
34RDEPENDS:${PN}-ptest += "\
35 ${PN}-test \
36 python3-pytest \
37 python3-unittest-automake-output \
38 python3-unixadmin \
39"
40
41do_compile:prepend() {
42 echo [global] > ${S}/setup.cfg
43 echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg
44 echo have_sys_un_h = True >> ${S}/setup.cfg
45 echo skip_check_zmq = True >> ${S}/setup.cfg
46 echo libzmq_extension = False >> ${S}/setup.cfg
47 echo no_libzmq_extension = True >> ${S}/setup.cfg
48}
49
50do_install:append() {
51 sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/config.json
52 sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/compiler.json
53}
54
55do_install_ptest() {
56 install -d ${D}${PTEST_PATH}/tests
57 cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
58}
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_26.3.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_26.3.0.bb
new file mode 100644
index 0000000000..c7225aa259
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_26.3.0.bb
@@ -0,0 +1,60 @@
1SUMMARY = "PyZMQ: Python bindings for ZMQ"
2DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
3HOMEPAGE = "https://zeromq.org/bindings:python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.md;md5=1787206f198344195a671b60326c59dc \
7"
8
9DEPENDS = "python3-packaging-native \
10 python3-setuptools-scm-native \
11 python3-scikit-build-core-native \
12 cmake-native \
13 ninja-native \
14 zeromq \
15"
16
17PEP517_BUILD_OPTS = "--skip-dependency-check \
18 -Ccmake.define.PYZMQ_LIBZMQ_RPATH=OFF \
19 -Ccmake.define.PYZMQ_NO_BUNDLE=ON \
20 -Ccmake.define.CMAKE_FIND_ROOT_PATH_MODE_PACKAGE=ONLY \
21 -Ccmake.define.CMAKE_FIND_ROOT_PATH_MODE_PROGRAM=ONLY \
22 -Ccmake.define.CMAKE_FIND_ROOT_PATH_MODE_LIBRARY=ONLY \
23 -Ccmake.define.CMAKE_FIND_ROOT_PATH_MODE_INCLUDE=ONLY \
24 -Ccmake.define.CMAKE_FIND_ROOT_PATH="${STAGING_DIR_NATIVE}" \
25 -Ccmake.build-type="RelWithDebInfo" \
26"
27
28SRC_URI:append = " \
29 file://run-ptest \
30"
31
32SRC_URI[sha256sum] = "f1cd68b8236faab78138a8fc703f7ca0ad431b17a3fcac696358600d4e6243b3"
33
34inherit pypi pkgconfig python_setuptools_build_meta ptest cython
35
36PACKAGES =+ "\
37 ${PN}-test \
38"
39
40FILES:${PN}-test += "\
41 ${PYTHON_SITEPACKAGES_DIR}/*/tests \
42"
43
44RDEPENDS:${PN} += "\
45 python3-json \
46 python3-multiprocessing \
47 python3-tornado \
48"
49
50RDEPENDS:${PN}-ptest += "\
51 ${PN}-test \
52 python3-pytest \
53 python3-unittest-automake-output \
54 python3-unixadmin \
55"
56
57do_install_ptest() {
58 install -d ${D}${PTEST_PATH}/tests
59 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
60}