diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch | 28 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb) | 9 |
2 files changed, 4 insertions, 33 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch deleted file mode 100644 index 526a3b1fb2..0000000000 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 3bb8d08bdec2f79bb13c0a44b81718d26e5bdabc Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Mon, 8 May 2017 16:30:20 +0800 | ||
4 | Subject: [PATCH 04/11] fix new.roots object is not iterable | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
9 | --- | ||
10 | blivet/blivet.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/blivet/blivet.py b/blivet/blivet.py | ||
14 | index ea08837..91c92b2 100644 | ||
15 | --- a/blivet/blivet.py | ||
16 | +++ b/blivet/blivet.py | ||
17 | @@ -1206,7 +1206,7 @@ class Blivet(object): | ||
18 | p = partition.disk.format.parted_disk.getPartitionByPath(partition.path) | ||
19 | partition.parted_partition = p | ||
20 | |||
21 | - for root in new.roots: | ||
22 | + for root in new.roots or []: | ||
23 | root.swaps = [new.devicetree.get_device_by_id(d.id, hidden=True) for d in root.swaps] | ||
24 | root.swaps = [s for s in root.swaps if s] | ||
25 | |||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb index bd57604f26..52b3aa7dc7 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb | |||
@@ -8,7 +8,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
8 | SRC_URI += "\ | 8 | SRC_URI += "\ |
9 | file://0002-run_program-support-timeout.patch \ | 9 | file://0002-run_program-support-timeout.patch \ |
10 | file://0003-support-infinit-timeout.patch \ | 10 | file://0003-support-infinit-timeout.patch \ |
11 | file://0004-fix-new.roots-object-is-not-iterable.patch \ | ||
12 | file://0005-fix-incorrect-timeout-while-system-time-changed.patch \ | 11 | file://0005-fix-incorrect-timeout-while-system-time-changed.patch \ |
13 | file://0006-tweak-btrfs-packages.patch \ | 12 | file://0006-tweak-btrfs-packages.patch \ |
14 | file://0007-invoking-mount-with-infinite-timeout.patch \ | 13 | file://0007-invoking-mount-with-infinite-timeout.patch \ |
@@ -17,16 +16,16 @@ SRC_URI += "\ | |||
17 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ | 16 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
18 | file://0011-invoking-dd-with-infinite-timeout.patch \ | 17 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
19 | " | 18 | " |
20 | SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48" | 19 | SRC_URI[sha256sum] = "88d1500c76c4660aec7da9e9aa54f7f574546571b52c07a67e1417883c2cb25b" |
21 | 20 | ||
22 | inherit pypi features_check systemd setuptools3_legacy | 21 | inherit pypi features_check systemd setuptools3_legacy |
23 | 22 | ||
24 | REQUIRED_DISTRO_FEATURES = "systemd" | 23 | REQUIRED_DISTRO_FEATURES = "systemd" |
25 | 24 | ||
26 | RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \ | 25 | RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \ |
27 | parted python3-pyparted multipath-tools \ | 26 | parted python3-pyparted multipath-tools \ |
28 | lsof cryptsetup libblockdev \ | 27 | lsof cryptsetup libblockdev \ |
29 | libbytesize \ | 28 | libbytesize \ |
30 | " | 29 | " |
31 | 30 | ||
32 | FILES:${PN} += " \ | 31 | FILES:${PN} += " \ |