summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-docopt_0.6.2.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb1
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index f62117e634..582037be59 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -261,6 +261,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
261 python3-pyiface \ 261 python3-pyiface \
262 python3-pyjwt \ 262 python3-pyjwt \
263 python3-pykwalify \ 263 python3-pykwalify \
264 python3-docopt \
264 python3-pylint \ 265 python3-pylint \
265 python3-pynetlinux \ 266 python3-pynetlinux \
266 python3-pickleshare \ 267 python3-pickleshare \
diff --git a/meta-python/recipes-devtools/python/python3-docopt_0.6.2.bb b/meta-python/recipes-devtools/python/python3-docopt_0.6.2.bb
new file mode 100644
index 0000000000..a2432068cc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-docopt_0.6.2.bb
@@ -0,0 +1,11 @@
1SUMMARY = "Pythonic argument parser, that will make you smile"
2HOMEPAGE = "http://docopt.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=09b77fb74986791a3d4a0e746a37d88f"
5
6inherit setuptools3 pypi
7
8SRC_URI[md5sum] = "4bc74561b37fad5d3e7d037f82a4c3b1"
9SRC_URI[sha256sum] = "49b3a825280bd66b3aa83585ef59c4a8c82f2c8a522dbe754a8bc8d08c85c491"
10
11BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb b/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb
index 770503f50b..2df30aeab8 100644
--- a/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pykwalify_1.7.0.bb
@@ -14,6 +14,7 @@ inherit setuptools3 pypi
14unset _PYTHON_SYSCONFIGDATA_NAME 14unset _PYTHON_SYSCONFIGDATA_NAME
15 15
16RDEPENDS_${PN} = "\ 16RDEPENDS_${PN} = "\
17 ${PYTHON_PN}-docopt \
17 ${PYTHON_PN}-dateutil \ 18 ${PYTHON_PN}-dateutil \
18 ${PYTHON_PN}-pyyaml \ 19 ${PYTHON_PN}-pyyaml \
19" 20"