summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-python-multipart/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-python-multipart_0.0.11.bb9
-rw-r--r--meta-python/recipes-devtools/python/python3-python-multipart_0.0.12.bb24
4 files changed, 28 insertions, 9 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 25d71a2b6f..7864b632a7 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -53,6 +53,7 @@ PTESTS_FAST_META_PYTHON = "\
53 python3-pydantic \ 53 python3-pydantic \
54 python3-pydantic-core \ 54 python3-pydantic-core \
55 python3-pylint \ 55 python3-pylint \
56 python3-python-multipart \
56 python3-ptyprocess \ 57 python3-ptyprocess \
57 python3-py-cpuinfo \ 58 python3-py-cpuinfo \
58 python3-pyasn1-modules \ 59 python3-pyasn1-modules \
diff --git a/meta-python/recipes-devtools/python/python3-python-multipart/run-ptest b/meta-python/recipes-devtools/python/python3-python-multipart/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-python-multipart/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-python-multipart_0.0.11.bb b/meta-python/recipes-devtools/python/python3-python-multipart_0.0.11.bb
deleted file mode 100644
index b325f90ad3..0000000000
--- a/meta-python/recipes-devtools/python/python3-python-multipart_0.0.11.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1SUMMARY = "A streaming multipart parser for Python"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3d98f0d58b28321924a89ab60c82410e"
4
5SRC_URI[sha256sum] = "1d377f074b69a47dd204c990de57a7cf03d9b85695a3e57faec32d54b78e3e48"
6
7inherit pypi python_hatchling
8
9PYPI_PACKAGE = "python_multipart"
diff --git a/meta-python/recipes-devtools/python/python3-python-multipart_0.0.12.bb b/meta-python/recipes-devtools/python/python3-python-multipart_0.0.12.bb
new file mode 100644
index 0000000000..340e297b83
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-python-multipart_0.0.12.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A streaming multipart parser for Python"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3d98f0d58b28321924a89ab60c82410e"
4
5SRC_URI[sha256sum] = "045e1f98d719c1ce085ed7f7e1ef9d8ccc8c02ba02b5566d5f7521410ced58cb"
6
7inherit pypi python_hatchling ptest
8
9PYPI_PACKAGE = "python_multipart"
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest = " \
16 python3-pytest \
17 python3-pyyaml \
18 python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}