diff options
Diffstat (limited to 'meta-python')
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-login.inc b/meta-python/recipes-devtools/python/python-flask-login.inc new file mode 100644 index 0000000000..95c4428c0d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-login.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "User session management for Flask" | ||
2 | DESCRIPTION = "Flask-Login provides user session management for Flask. \ | ||
3 | It handles the common tasks of logging in, logging out, and remembering \ | ||
4 | your users’ sessions over extended periods of time." | ||
5 | HOMEPAGE = " https://github.com/maxcountryman/flask-login" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8aa87a1cd9fa41d969ad32cfdac2c596" | ||
8 | |||
9 | SRC_URI[md5sum] = "c0a7eaf28623f0aeac4929dc05a7a064" | ||
10 | SRC_URI[sha256sum] = "83d5f10e5c4f214feed6cc41c212db63a58a15ac32e56df81591bfa0a5cee3e5" | ||
11 | |||
12 | PYPI_PACKAGE = "Flask-Login" | ||
13 | |||
14 | RDEPENDS_${PN} = "${PYTHON_PN}-flask" | ||
diff --git a/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb b/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb new file mode 100644 index 0000000000..c6dce37d4a --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-login_0.2.11.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi | ||
2 | require python-flask-login.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-flask-login_0.2.11.bb b/meta-python/recipes-devtools/python/python3-flask-login_0.2.11.bb new file mode 100644 index 0000000000..5d46954a5b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-flask-login_0.2.11.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi3 | ||
2 | require python-flask-login.inc | ||