diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-more-itertools/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-more-itertools_8.5.0.bb | 24 |
2 files changed, 0 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python3-more-itertools/run-ptest b/meta-python/recipes-devtools/python/python3-more-itertools/run-ptest deleted file mode 100644 index 3385d68939..0000000000 --- a/meta-python/recipes-devtools/python/python3-more-itertools/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-more-itertools_8.5.0.bb b/meta-python/recipes-devtools/python/python3-more-itertools_8.5.0.bb deleted file mode 100644 index e924b0f731..0000000000 --- a/meta-python/recipes-devtools/python/python3-more-itertools_8.5.0.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | DESCRIPTION = "More routines for operating on iterables, beyond itertools" | ||
2 | HOMEPAGE = "https://github.com/erikrose/more-itertools" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5" | ||
5 | |||
6 | SRC_URI[md5sum] = "2588b5a7042576b99574779582be9292" | ||
7 | SRC_URI[sha256sum] = "6f83822ae94818eae2612063a5101a7311e68ae8002005b5e05f03fd74a86a20" | ||
8 | |||
9 | inherit pypi setuptools3 ptest | ||
10 | |||
11 | BBCLASSEXTEND = "native nativesdk" | ||
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS_${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | " | ||
20 | |||
21 | do_install_ptest() { | ||
22 | install -d ${D}${PTEST_PATH}/tests | ||
23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
24 | } | ||