diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pycurl.inc | 25 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb | 24 |
2 files changed, 22 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycurl.inc b/meta-python/recipes-devtools/python/python-pycurl.inc deleted file mode 100644 index 0f661434c0..0000000000 --- a/meta-python/recipes-devtools/python/python-pycurl.inc +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SUMMARY = "A Python Interface To The cURL library" | ||
2 | DESCRIPTION = "\ | ||
3 | PycURL is a Python interface to libcurl, the multiprotocol file \ | ||
4 | transfer library. Similarly to the urllib Python module, PycURL can \ | ||
5 | be used to fetch objects identified by a URL from a Python program \ | ||
6 | " | ||
7 | SECTION = "devel/python" | ||
8 | HOMEPAGE = "http://pycurl.io/" | ||
9 | |||
10 | LICENSE = "LGPLv2 | MIT" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \ | ||
12 | file://COPYING-MIT;md5=60872a112595004233b769b6cbfd65b6 \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "0b387d4609ed20c88baede8579a4d425" | ||
16 | SRC_URI[sha256sum] = "ec7dd291545842295b7b56c12c90ffad2976cc7070c98d7b1517b7b6cd5994b3" | ||
17 | |||
18 | inherit pypi | ||
19 | |||
20 | PYPI_PACKAGE = "pycurl" | ||
21 | |||
22 | DEPENDS = "\ | ||
23 | curl \ | ||
24 | ${PYTHON_PN}\ | ||
25 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb index c98b7d6f60..5a1c1797ad 100644 --- a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb +++ b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb | |||
@@ -1,3 +1,23 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "A Python Interface To The cURL library" |
2 | require python-pycurl.inc | 2 | DESCRIPTION = "\ |
3 | PycURL is a Python interface to libcurl, the multiprotocol file \ | ||
4 | transfer library. Similarly to the urllib Python module, PycURL can \ | ||
5 | be used to fetch objects identified by a URL from a Python program \ | ||
6 | " | ||
7 | SECTION = "devel/python" | ||
8 | HOMEPAGE = "http://pycurl.io/" | ||
3 | 9 | ||
10 | LICENSE = "LGPLv2 | MIT" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \ | ||
12 | file://COPYING-MIT;md5=60872a112595004233b769b6cbfd65b6 \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "0b387d4609ed20c88baede8579a4d425" | ||
16 | SRC_URI[sha256sum] = "ec7dd291545842295b7b56c12c90ffad2976cc7070c98d7b1517b7b6cd5994b3" | ||
17 | |||
18 | inherit pypi setuptools3 | ||
19 | |||
20 | DEPENDS = "\ | ||
21 | curl \ | ||
22 | ${PYTHON_PN}\ | ||
23 | " | ||