summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse-type_0.6.2.bb (renamed from meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb)12
1 files changed, 3 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb b/meta-python/recipes-devtools/python/python3-parse-type_0.6.2.bb
index 7eebbfb503..99493db322 100644
--- a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-parse-type_0.6.2.bb
@@ -1,15 +1,14 @@
1SUMMARY = "Simplifies building parse types based on the parse module" 1SUMMARY = "Simplifies building parse types based on the parse module"
2HOMEPAGE = "https://github.com/jenisys/parse_type" 2HOMEPAGE = "https://github.com/jenisys/parse_type"
3LICENSE = "BSD-3-Clause" 3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=16374dbaeaca1890153edb3f41371222" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=2e469278ace89c246d52505acc39c3da"
5 5
6SRC_URI[md5sum] = "b954062f14ab723a91fe1e2be15e859d" 6SRC_URI[sha256sum] = "79b1f2497060d0928bc46016793f1fca1057c4aacdf15ef876aa48d75a73a355"
7SRC_URI[sha256sum] = "7f690b18d35048c15438d6d0571f9045cffbec5907e0b1ccf006f889e3a38c0b"
8 7
9PYPI_PACKAGE = "parse_type" 8PYPI_PACKAGE = "parse_type"
10inherit pypi ptest setuptools3 9inherit pypi ptest setuptools3
11 10
12RDEPENDS:${PN} += "${PYTHON_PN}-parse ${PYTHON_PN}-six" 11RDEPENDS:${PN} += "${PYTHON_PN}-parse"
13 12
14SRC_URI += " \ 13SRC_URI += " \
15 file://run-ptest \ 14 file://run-ptest \
@@ -19,11 +18,6 @@ RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \ 18 ${PYTHON_PN}-pytest \
20" 19"
21 20
22do_configure:prepend() {
23 sed -i -e "/python_version >= 3.0/d" ${S}/setup.py
24 sed -i -e "/use_2to3/d" ${S}/setup.py
25}
26
27do_install_ptest() { 21do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests 22 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ 23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/