summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-outcome/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb13
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-outcome/run-ptest b/meta-python/recipes-devtools/python/python3-outcome/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-outcome/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb b/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb
index 9714301879..308eb78a79 100644
--- a/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb
+++ b/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb
@@ -7,16 +7,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa7b86389e58dd4087a8d2b833e5fe96 \
7 7
8SRC_URI[sha256sum] = "9dcf02e65f2971b80047b377468e72a268e15c0af3cf1238e6ff14f7f91143b8" 8SRC_URI[sha256sum] = "9dcf02e65f2971b80047b377468e72a268e15c0af3cf1238e6ff14f7f91143b8"
9 9
10inherit pypi setuptools3 ptest 10inherit pypi setuptools3 ptest-python-pytest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15 11
16RDEPENDS:${PN}-ptest += " \ 12RDEPENDS:${PN}-ptest += " \
17 python3-pytest \
18 python3-pytest-asyncio \ 13 python3-pytest-asyncio \
19 python3-unittest-automake-output \
20 python3-outcome \ 14 python3-outcome \
21" 15"
22 16
@@ -27,8 +21,3 @@ RDEPENDS:${PN} += " \
27 python3-pytest \ 21 python3-pytest \
28 python3-typing-extensions \ 22 python3-typing-extensions \
29" 23"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34}