diff options
-rw-r--r-- | recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator/0002-Fix-compilation-with-QT_NO_ACCESSIBILITY.patch | 35 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch | 20 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator/0003-Qmlpuppet-add-missing-includes.patch | 38 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch | 30 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator_4.5.1.bb (renamed from recipes-qt/qt5/qt5-creator_3.5.1.bb) | 38 |
6 files changed, 36 insertions, 131 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch b/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch index c4ee34bf..28dc4755 100644 --- a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch +++ b/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 056bc88a15df06443a4a6bdea2b1ead045f89bf6 Mon Sep 17 00:00:00 2001 | 1 | From 231e0cf0c764d3b63cd5ec788ac0ee901b47fc8e Mon Sep 17 00:00:00 2001 |
2 | From: Greg Nietsky <gregory@distrotech.co.za> | 2 | From: Greg Nietsky <gregory@distrotech.co.za> |
3 | Date: Tue, 4 Mar 2014 11:33:40 +0200 | 3 | Date: Tue, 4 Mar 2014 11:33:40 +0200 |
4 | Subject: [PATCH] Fix: Allow qt-creator to build on arm aarch32 and aarch64 | 4 | Subject: [PATCH] Fix: Allow qt-creator to build on arm aarch32 and aarch64 |
@@ -14,7 +14,7 @@ Change-Id: Iddea28f21c9fa1afd2fdd5d16a44e6c96a516a7a | |||
14 | 2 files changed, 17 insertions(+), 1 deletion(-) | 14 | 2 files changed, 17 insertions(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp | 16 | diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp |
17 | index e6a5f22..7b625ac 100644 | 17 | index 87736d5..2e950d8 100644 |
18 | --- a/src/libs/3rdparty/botan/botan.cpp | 18 | --- a/src/libs/3rdparty/botan/botan.cpp |
19 | +++ b/src/libs/3rdparty/botan/botan.cpp | 19 | +++ b/src/libs/3rdparty/botan/botan.cpp |
20 | @@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator | 20 | @@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator |
@@ -76,7 +76,7 @@ index e6a5f22..7b625ac 100644 | |||
76 | * Helper Macros for x86 Assembly | 76 | * Helper Macros for x86 Assembly |
77 | */ | 77 | */ |
78 | diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h | 78 | diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h |
79 | index 2caa4a3..39b8079 100644 | 79 | index d7b90cc..26ca8ac 100644 |
80 | --- a/src/libs/3rdparty/botan/botan.h | 80 | --- a/src/libs/3rdparty/botan/botan.h |
81 | +++ b/src/libs/3rdparty/botan/botan.h | 81 | +++ b/src/libs/3rdparty/botan/botan.h |
82 | @@ -85,7 +85,9 @@ | 82 | @@ -85,7 +85,9 @@ |
diff --git a/recipes-qt/qt5/qt5-creator/0002-Fix-compilation-with-QT_NO_ACCESSIBILITY.patch b/recipes-qt/qt5/qt5-creator/0002-Fix-compilation-with-QT_NO_ACCESSIBILITY.patch deleted file mode 100644 index 8d953c99..00000000 --- a/recipes-qt/qt5/qt5-creator/0002-Fix-compilation-with-QT_NO_ACCESSIBILITY.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | From fbae8e85e74976b79308c203d38839b364757302 Mon Sep 17 00:00:00 2001 | ||
2 | From: Eike Ziller <eike.ziller@qt.io> | ||
3 | Date: Fri, 24 Jun 2016 10:23:24 +0200 | ||
4 | Subject: [PATCH] Fix compilation with QT_NO_ACCESSIBILITY | ||
5 | |||
6 | Task-number: QTCREATORBUG-16446 | ||
7 | Change-Id: If75122c23a697f26ccf56391fe2e8d316aad6367 | ||
8 | Reviewed-by: hjk <hjk@theqtcompany.com> | ||
9 | --- | ||
10 | src/libs/utils/fancymainwindow.cpp | 7 +++++-- | ||
11 | 1 file changed, 5 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/src/libs/utils/fancymainwindow.cpp b/src/libs/utils/fancymainwindow.cpp | ||
14 | index 9477f17..1ee425f 100644 | ||
15 | --- a/src/libs/utils/fancymainwindow.cpp | ||
16 | +++ b/src/libs/utils/fancymainwindow.cpp | ||
17 | @@ -159,13 +159,16 @@ public: | ||
18 | |||
19 | m_floatButton = new DockWidgetTitleButton(this); | ||
20 | m_floatButton->setIcon(q->style()->standardIcon(QStyle::SP_TitleBarNormalButton, &opt, q)); | ||
21 | - m_floatButton->setAccessibleName(QDockWidget::tr("Float")); | ||
22 | - m_floatButton->setAccessibleDescription(QDockWidget::tr("Undocks and re-attaches the dock widget")); | ||
23 | |||
24 | m_closeButton = new DockWidgetTitleButton(this); | ||
25 | m_closeButton->setIcon(q->style()->standardIcon(QStyle::SP_TitleBarCloseButton, &opt, q)); | ||
26 | + | ||
27 | +#ifndef QT_NO_ACCESSIBILITY | ||
28 | + m_floatButton->setAccessibleName(QDockWidget::tr("Float")); | ||
29 | + m_floatButton->setAccessibleDescription(QDockWidget::tr("Undocks and re-attaches the dock widget")); | ||
30 | m_closeButton->setAccessibleName(QDockWidget::tr("Close")); | ||
31 | m_closeButton->setAccessibleDescription(QDockWidget::tr("Closes the dock widget")); | ||
32 | +#endif | ||
33 | |||
34 | setActive(false); | ||
35 | |||
diff --git a/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch new file mode 100644 index 00000000..40e277fe --- /dev/null +++ b/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | From a30f4335d49516eb4654111af5bf073b633f7336 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 16 Jan 2018 13:26:57 +0000 | ||
4 | Subject: [PATCH] Link with libexecinfo on musl | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
8 | --- | ||
9 | src/plugins/debugger/debugger.pro | 1 + | ||
10 | 1 file changed, 1 insertion(+) | ||
11 | |||
12 | diff --git a/src/plugins/debugger/debugger.pro b/src/plugins/debugger/debugger.pro | ||
13 | index f5a34aa..4a1359d 100644 | ||
14 | --- a/src/plugins/debugger/debugger.pro | ||
15 | +++ b/src/plugins/debugger/debugger.pro | ||
16 | @@ -141,3 +141,4 @@ include(console/console.pri) | ||
17 | include(analyzer/analyzer.pri) | ||
18 | |||
19 | include(shared/shared.pri) | ||
20 | +LIBS *= -lexecinfo | ||
diff --git a/recipes-qt/qt5/qt5-creator/0003-Qmlpuppet-add-missing-includes.patch b/recipes-qt/qt5/qt5-creator/0003-Qmlpuppet-add-missing-includes.patch deleted file mode 100644 index e64b6d9a..00000000 --- a/recipes-qt/qt5/qt5-creator/0003-Qmlpuppet-add-missing-includes.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 896624d715e20e658344ac85db91cd55d25e7211 Mon Sep 17 00:00:00 2001 | ||
2 | From: Marco Benelli <marco.benelli@qt.io> | ||
3 | Date: Thu, 6 Jul 2017 09:31:41 +0200 | ||
4 | Subject: [PATCH] Qmlpuppet: add missing includes | ||
5 | |||
6 | Task-number: QTCREATORBUG-18498 | ||
7 | Change-Id: Ie40a066508bb52f53b8ad528f9d4cf6969fc0632 | ||
8 | Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io> | ||
9 | --- | ||
10 | .../qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.cpp | 2 ++ | ||
11 | .../qtcreator/qml/qmlpuppet/qml2puppet/instances/objectnodeinstance.cpp | 1 + | ||
12 | 2 files changed, 3 insertions(+) | ||
13 | |||
14 | diff --git a/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.cpp b/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.cpp | ||
15 | index 3f9f148..160e5c4 100644 | ||
16 | --- a/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.cpp | ||
17 | +++ b/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.cpp | ||
18 | @@ -29,6 +29,8 @@ | ||
19 | ****************************************************************************/ | ||
20 | #include "layoutnodeinstance.h" | ||
21 | |||
22 | +#include <QCoreApplication> | ||
23 | + | ||
24 | namespace QmlDesigner { | ||
25 | namespace Internal { | ||
26 | |||
27 | diff --git a/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/objectnodeinstance.cpp b/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/objectnodeinstance.cpp | ||
28 | index 5a9342f..bacbc12 100644 | ||
29 | --- a/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/objectnodeinstance.cpp | ||
30 | +++ b/share/qtcreator/qml/qmlpuppet/qml2puppet/instances/objectnodeinstance.cpp | ||
31 | @@ -33,6 +33,7 @@ | ||
32 | #include <enumeration.h> | ||
33 | #include <qmlprivategate.h> | ||
34 | |||
35 | +#include <QDebug> | ||
36 | #include <QEvent> | ||
37 | #include <QQmlContext> | ||
38 | #include <QQmlError> | ||
diff --git a/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch deleted file mode 100644 index 59687e55..00000000 --- a/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From 7fb65b82d247123c7fdb61436183f1d76067b66b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 16 Jan 2018 13:26:57 +0000 | ||
4 | Subject: [PATCH] Link with libexecinfo on musl | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
8 | --- | ||
9 | src/plugins/debugger/debugger.pro | 1 + | ||
10 | src/plugins/qmldesigner/config.pri | 1 + | ||
11 | 2 files changed, 2 insertions(+) | ||
12 | |||
13 | diff --git a/src/plugins/debugger/debugger.pro b/src/plugins/debugger/debugger.pro | ||
14 | index c40bd63..96ab542 100644 | ||
15 | --- a/src/plugins/debugger/debugger.pro | ||
16 | +++ b/src/plugins/debugger/debugger.pro | ||
17 | @@ -148,3 +148,4 @@ include(qml/qml.pri) | ||
18 | include(namedemangler/namedemangler.pri) | ||
19 | |||
20 | include(shared/shared.pri) | ||
21 | +LIBS *= -lexecinfo | ||
22 | diff --git a/src/plugins/qmldesigner/config.pri b/src/plugins/qmldesigner/config.pri | ||
23 | index 1b559b2..b485b63 100644 | ||
24 | --- a/src/plugins/qmldesigner/config.pri | ||
25 | +++ b/src/plugins/qmldesigner/config.pri | ||
26 | @@ -9,3 +9,4 @@ equals(TMP_BAUHAUS_NO_OUTPUT, true):DEFINES += QT_NO_DEBUG_OUTPUT \ | ||
27 | DEFINES += ENABLE_TEXT_VIEW | ||
28 | |||
29 | isEmpty($$(BAUHAUS_OUTPUT_IN_TEST)):DEFINES += QDEBUG_IN_TESTS WARNINGS_IN_TESTS | ||
30 | +LIBS *= -lexecinfo | ||
diff --git a/recipes-qt/qt5/qt5-creator_3.5.1.bb b/recipes-qt/qt5/qt5-creator_4.5.1.bb index fe9cb414..e97e591e 100644 --- a/recipes-qt/qt5/qt5-creator_3.5.1.bb +++ b/recipes-qt/qt5/qt5-creator_4.5.1.bb | |||
@@ -7,11 +7,9 @@ SUMMARY = "Qt Creator is a new cross-platform Qt IDE" | |||
7 | # 'System GDB at /usr/bin/gdb. | 7 | # 'System GDB at /usr/bin/gdb. |
8 | 8 | ||
9 | HOMEPAGE = "https://qt-project.org/" | 9 | HOMEPAGE = "https://qt-project.org/" |
10 | LICENSE = "LGPLv2.1 | GPLv3" | 10 | LICENSE = "GPLv3" |
11 | LIC_FILES_CHKSUM = " \ | 11 | LIC_FILES_CHKSUM = " \ |
12 | file://LGPL_EXCEPTION.TXT;md5=f4748b0d1a72c5c8fb5dab2dd1f7fa46 \ | 12 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ |
13 | file://LICENSE.LGPLv21;md5=825920de5f6db2eeb1bebe625476346d \ | ||
14 | file://LICENSE.LGPLv3;md5=0786418af032b9e608909874f334a2d1 \ | ||
15 | " | 13 | " |
16 | 14 | ||
17 | inherit qmake5 | 15 | inherit qmake5 |
@@ -19,39 +17,25 @@ inherit qmake5 | |||
19 | DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg qtquick1" | 17 | DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg qtquick1" |
20 | DEPENDS_append_libc-musl = " libexecinfo" | 18 | DEPENDS_append_libc-musl = " libexecinfo" |
21 | 19 | ||
22 | # Patches from https://github.com/meta-qt5/qtcreator/commits/b5.3.1 | 20 | # Patches from https://github.com/meta-qt5/qtcreator/commits/b5.4.1 |
23 | # 5.3.1.meta-qt5.1 | 21 | # 5.4.1.meta-qt5.1 |
24 | SRC_URI = " \ | 22 | SRC_URI = " \ |
25 | http://download.qt.io/official_releases/qtcreator/3.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \ | 23 | http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \ |
26 | file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \ | 24 | file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \ |
27 | file://0002-Fix-compilation-with-QT_NO_ACCESSIBILITY.patch \ | ||
28 | file://0003-Qmlpuppet-add-missing-includes.patch \ | ||
29 | file://qtcreator.desktop.in \ | 25 | file://qtcreator.desktop.in \ |
30 | " | 26 | " |
27 | SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch" | ||
31 | 28 | ||
32 | SRC_URI_append_libc-musl = " file://0004-Link-with-libexecinfo-on-musl.patch" | 29 | SRC_URI[md5sum] = "bd7fdbcdfa84df1171fb28174353e57f" |
33 | 30 | SRC_URI[sha256sum] = "5fdfc8f05694e37162f208616627262c9971749d6958d8881d62933b3b53e909" | |
34 | |||
35 | SRC_URI[md5sum] = "77aef7df837eba07c7ce6037ee504c05" | ||
36 | SRC_URI[sha256sum] = "5925ac818a08be919094e0f28fb4c5d8896765e0975d54d353e4c50f13d63e65" | ||
37 | 31 | ||
38 | S = "${WORKDIR}/qt-creator-opensource-src-${PV}" | 32 | S = "${WORKDIR}/qt-creator-opensource-src-${PV}" |
39 | 33 | ||
40 | EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}" | 34 | EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}" |
41 | 35 | ||
42 | LDFLAGS_append_libc-musl = " -lexecinfo " | ||
43 | do_configure_append() { | 36 | do_configure_append() { |
44 | # Find native tools | 37 | # Find native tools |
45 | sed -i 's:${STAGING_BINDIR}.*/lrelease:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/lrelease:g' ${B}/share/qtcreator/translations/Makefile | ||
46 | sed -i 's:${STAGING_BINDIR}.*/qdoc:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qdoc:g' ${B}/Makefile | 38 | sed -i 's:${STAGING_BINDIR}.*/qdoc:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qdoc:g' ${B}/Makefile |
47 | |||
48 | # see qtbase-native.inc | ||
49 | # sed -i 's:QT_INSTALL_DOCS=${docdir}:QT_INSTALL_DOCS=${STAGING_DATADIR_NATIVE}${QT_DIR_NAME}/doc:g' ${B}/Makefile | ||
50 | } | ||
51 | |||
52 | do_compile_append() { | ||
53 | # build docs | ||
54 | #oe_runmake docs_online | ||
55 | } | 39 | } |
56 | 40 | ||
57 | do_install() { | 41 | do_install() { |
@@ -65,6 +49,7 @@ do_install() { | |||
65 | 49 | ||
66 | FILES_${PN} += " \ | 50 | FILES_${PN} += " \ |
67 | ${datadir}/qtcreator \ | 51 | ${datadir}/qtcreator \ |
52 | ${datadir}/metainfo \ | ||
68 | ${datadir}/icons \ | 53 | ${datadir}/icons \ |
69 | ${libdir}${QT_DIR_NAME}/qtcreator \ | 54 | ${libdir}${QT_DIR_NAME}/qtcreator \ |
70 | " | 55 | " |
@@ -79,7 +64,7 @@ FILES_${PN}-dev += " \ | |||
79 | ${libdir}${QT_DIR_NAME}/qtcreator/*${SOLIBSDEV} \ | 64 | ${libdir}${QT_DIR_NAME}/qtcreator/*${SOLIBSDEV} \ |
80 | " | 65 | " |
81 | 66 | ||
82 | RDEPENDS_${PN} += "perl" | 67 | RDEPENDS_${PN} += "perl python" |
83 | RCONFLICTS_${PN} = "qt-creator" | 68 | RCONFLICTS_${PN} = "qt-creator" |
84 | 69 | ||
85 | # To give best user experience out of the box.. | 70 | # To give best user experience out of the box.. |
@@ -91,3 +76,6 @@ RRECOMMENDS_${PN} += " \ | |||
91 | gcc-symlinks g++-symlinks cpp-symlinks \ | 76 | gcc-symlinks g++-symlinks cpp-symlinks \ |
92 | gdb \ | 77 | gdb \ |
93 | " | 78 | " |
79 | |||
80 | # ERROR: qt5-creator-4.5.1-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: '/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qt5-creator/4.5.1-r0/packages-split/qt5-creator/usr/lib/qt5/qtcreator/libqbscore.so.1.10.1' | ||
81 | INSANE_SKIP_${PN} += "ldflags" | ||