summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch131
-rw-r--r--recipes-qt/qwt/qwt-qt5_6.1.5.bb (renamed from recipes-qt/qwt/qwt-qt5_6.1.4.bb)4
2 files changed, 1 insertions, 134 deletions
diff --git a/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch b/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch
deleted file mode 100644
index 5caf7930..00000000
--- a/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch
+++ /dev/null
@@ -1,131 +0,0 @@
1From c44af9a6f0eff02b439ef770755da551f281e9ad Mon Sep 17 00:00:00 2001
2From: rathmann <rathmann@29e17f8d-cf37-471e-a288-72cc03a76eda>
3Date: Sun, 29 Mar 2020 09:11:29 +0000
4Subject: [PATCH] missing qpainterpath.h include added needed with Qt 5.15
5 Beta2
6
7Partial backport from
8https://sourceforge.net/p/qwt/code/3187/
9
10---
11diff -uNr qwt-6.1.4.orig/src/qwt_compass_rose.cpp qwt-6.1.4/src/qwt_compass_rose.cpp
12--- qwt-6.1.4.orig/src/qwt_compass_rose.cpp 2019-01-02 17:21:31.280460826 +0100
13+++ qwt-6.1.4/src/qwt_compass_rose.cpp 2020-04-14 13:33:27.214932546 +0200
14@@ -11,6 +11,7 @@
15 #include "qwt_point_polar.h"
16 #include "qwt_painter.h"
17 #include <qpainter.h>
18+#include <qpainterpath.h>
19
20 static QPointF qwtIntersection(
21 QPointF p11, QPointF p12, QPointF p21, QPointF p22 )
22diff -uNr qwt-6.1.4.orig/src/qwt_dial_needle.cpp qwt-6.1.4/src/qwt_dial_needle.cpp
23--- qwt-6.1.4.orig/src/qwt_dial_needle.cpp 2019-01-02 17:21:31.284460922 +0100
24+++ qwt-6.1.4/src/qwt_dial_needle.cpp 2020-04-14 13:33:37.006864250 +0200
25@@ -13,6 +13,7 @@
26 #include "qwt_painter.h"
27 #include <qapplication.h>
28 #include <qpainter.h>
29+#include <qpainterpath.h>
30
31 #if QT_VERSION < 0x040601
32 #define qFastSin(x) qSin(x)
33diff -uNr qwt-6.1.4.orig/src/qwt_null_paintdevice.cpp qwt-6.1.4/src/qwt_null_paintdevice.cpp
34--- qwt-6.1.4.orig/src/qwt_null_paintdevice.cpp 2019-01-02 17:21:31.296461212 +0100
35+++ qwt-6.1.4/src/qwt_null_paintdevice.cpp 2020-04-14 13:31:21.983807348 +0200
36@@ -9,6 +9,7 @@
37
38 #include "qwt_null_paintdevice.h"
39 #include <qpaintengine.h>
40+#include <qpainterpath.h>
41 #include <qpixmap.h>
42
43 class QwtNullPaintDevice::PrivateData
44diff -uNr qwt-6.1.4.orig/src/qwt_painter_command.h qwt-6.1.4/src/qwt_painter_command.h
45--- qwt-6.1.4.orig/src/qwt_painter_command.h 2020-04-14 13:29:35.128556140 +0200
46+++ qwt-6.1.4/src/qwt_painter_command.h 2020-04-14 13:28:23.957056341 +0200
47@@ -15,6 +15,7 @@
48 #include <qpixmap.h>
49 #include <qimage.h>
50 #include <qpolygon.h>
51+#include <qpainterpath.h>
52
53 class QPainterPath;
54
55diff -uNr qwt-6.1.4.orig/src/qwt_painter.cpp qwt-6.1.4/src/qwt_painter.cpp
56--- qwt-6.1.4.orig/src/qwt_painter.cpp 2019-01-02 17:21:31.452464985 +0100
57+++ qwt-6.1.4/src/qwt_painter.cpp 2020-04-14 13:30:22.356224890 +0200
58@@ -19,6 +19,7 @@
59 #include <qpainter.h>
60 #include <qpalette.h>
61 #include <qpaintdevice.h>
62+#include <qpainterpath.h>
63 #include <qpixmap.h>
64 #include <qstyle.h>
65 #include <qtextdocument.h>
66diff -uNr qwt-6.1.4.orig/src/qwt_plot_glcanvas.cpp qwt-6.1.4/src/qwt_plot_glcanvas.cpp
67--- qwt-6.1.4.orig/src/qwt_plot_glcanvas.cpp 2019-01-02 17:21:31.300461309 +0100
68+++ qwt-6.1.4/src/qwt_plot_glcanvas.cpp 2020-04-14 13:33:14.947018129 +0200
69@@ -12,6 +12,7 @@
70 #include "qwt_painter.h"
71 #include <qevent.h>
72 #include <qpainter.h>
73+#include <qpainterpath.h>
74 #include <qdrawutil.h>
75 #include <qstyle.h>
76 #include <qstyleoption.h>
77diff -uNr qwt-6.1.4.orig/src/qwt_plot_panner.cpp qwt-6.1.4/src/qwt_plot_panner.cpp
78--- qwt-6.1.4.orig/src/qwt_plot_panner.cpp 2019-01-02 17:21:31.468465371 +0100
79+++ qwt-6.1.4/src/qwt_plot_panner.cpp 2020-04-14 13:32:33.259309129 +0200
80@@ -14,6 +14,7 @@
81 #include <qbitmap.h>
82 #include <qstyle.h>
83 #include <qstyleoption.h>
84+#include <qpainterpath.h>
85
86 #if QT_VERSION >= 0x050000
87 #if QT_VERSION < 0x050100
88diff -uNr qwt-6.1.4.orig/src/qwt_plot_renderer.cpp qwt-6.1.4/src/qwt_plot_renderer.cpp
89--- qwt-6.1.4.orig/src/qwt_plot_renderer.cpp 2019-01-02 17:21:31.352462567 +0100
90+++ qwt-6.1.4/src/qwt_plot_renderer.cpp 2020-04-14 13:31:51.019604276 +0200
91@@ -20,6 +20,7 @@
92 #include "qwt_math.h"
93
94 #include <qpainter.h>
95+#include <qpainterpath.h>
96 #include <qtransform.h>
97 #include <qprinter.h>
98 #include <qfiledialog.h>
99diff -uNr qwt-6.1.4.orig/src/qwt_widget_overlay.cpp qwt-6.1.4/src/qwt_widget_overlay.cpp
100--- qwt-6.1.4.orig/src/qwt_widget_overlay.cpp 2019-01-02 17:21:31.388463437 +0100
101+++ qwt-6.1.4/src/qwt_widget_overlay.cpp 2020-04-14 13:31:07.091911561 +0200
102@@ -11,6 +11,7 @@
103 #include "qwt_painter.h"
104 #include <qpainter.h>
105 #include <qpaintengine.h>
106+#include <qpainterpath.h>
107 #include <qimage.h>
108 #include <qevent.h>
109
110diff -uNr qwt-6.1.4.orig/examples/dials/attitude_indicator.cpp qwt-6.1.4/examples/dials/attitude_indicator.cpp
111--- qwt-6.1.4.orig/examples/dials/attitude_indicator.cpp 2019-01-02 17:21:31.164458020 +0100
112+++ qwt-6.1.4/examples/dials/attitude_indicator.cpp 2020-04-14 13:44:46.354218570 +0200
113@@ -3,6 +3,7 @@
114 #include <qwt_round_scale_draw.h>
115 #include <qevent.h>
116 #include <qpainter.h>
117+#include <qpainterpath.h>
118 #include <qpolygon.h>
119
120 AttitudeIndicatorNeedle::AttitudeIndicatorNeedle( const QColor &color )
121diff -uNr qwt-6.1.4.orig/src/qwt_plot_glcanvas.h qwt-6.1.4/src/qwt_plot_glcanvas.h
122--- qwt-6.1.4.orig/src/qwt_plot_glcanvas.h 2020-04-14 13:44:26.642354964 +0200
123+++ qwt-6.1.4/src/qwt_plot_glcanvas.h 2020-04-14 13:42:38.555103164 +0200
124@@ -12,6 +12,7 @@
125
126 #include "qwt_global.h"
127 #include <qframe.h>
128+#include <qpainterpath.h>
129 #include <qgl.h>
130
131 class QwtPlot;
diff --git a/recipes-qt/qwt/qwt-qt5_6.1.4.bb b/recipes-qt/qwt/qwt-qt5_6.1.5.bb
index 18eebbf1..b483af59 100644
--- a/recipes-qt/qwt/qwt-qt5_6.1.4.bb
+++ b/recipes-qt/qwt/qwt-qt5_6.1.5.bb
@@ -16,10 +16,8 @@ inherit qmake5
16SRC_URI = " \ 16SRC_URI = " \
17 ${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt \ 17 ${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt \
18 file://0001-Remove-rpath-from-binaries-they-point-to-buuild-area.patch \ 18 file://0001-Remove-rpath-from-binaries-they-point-to-buuild-area.patch \
19 file://0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch \
20" 19"
21SRC_URI[qwt.md5sum] = "4fb1852f694420e3ab9c583526edecc5" 20SRC_URI[qwt.sha256sum] = "4076de63ec2b5e84379ddfebf27c7b29b8dc9074f3db7e2ca61d11a1d8adc041"
22SRC_URI[qwt.sha256sum] = "1529215329e51fc562e0009505a838f427919a18b362afff441f035b2d9b5bd9"
23 21
24S = "${WORKDIR}/qwt-${PV}" 22S = "${WORKDIR}/qwt-${PV}"
25 23