diff options
-rw-r--r-- | recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/nativesdk-qtbase_git.bb | 18 |
2 files changed, 4 insertions, 16 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb index 4b46e676..e92cb9d4 100644 --- a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb +++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb | |||
@@ -10,6 +10,6 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" | |||
10 | RDEPENDS_${PN} += " \ | 10 | RDEPENDS_${PN} += " \ |
11 | nativesdk-packagegroup-sdk-host \ | 11 | nativesdk-packagegroup-sdk-host \ |
12 | nativesdk-qttools-tools \ | 12 | nativesdk-qttools-tools \ |
13 | nativesdk-qtbase-tools \ | 13 | nativesdk-qtbase \ |
14 | nativesdk-perl-modules \ | 14 | nativesdk-perl-modules \ |
15 | " | 15 | " |
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb index 5bea3c89..96d3e055 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bb +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb | |||
@@ -55,34 +55,22 @@ SRC_URI += " \ | |||
55 | file://OEQt5Toolchain.cmake \ | 55 | file://OEQt5Toolchain.cmake \ |
56 | " | 56 | " |
57 | 57 | ||
58 | PACKAGES = "${PN}-tools-dev ${PN}-tools-staticdev ${PN}-tools" | ||
59 | |||
60 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" | 58 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" |
61 | 59 | ||
62 | FILES_${PN}-tools-dev = " \ | 60 | FILES_${PN}-dev += " \ |
63 | ${includedir} \ | ||
64 | ${FILES_SOLIBSDEV} ${libdir}/*.la \ | ||
65 | ${libdir}/*.prl \ | ||
66 | ${OE_QMAKE_PATH_ARCHDATA}/mkspecs \ | 61 | ${OE_QMAKE_PATH_ARCHDATA}/mkspecs \ |
67 | ${OE_QMAKE_PATH_LIBS}/*.prl \ | 62 | ${OE_QMAKE_PATH_LIBS}/*.prl \ |
68 | " | 63 | " |
69 | 64 | ||
70 | FILES_${PN}-tools-staticdev = " \ | 65 | FILES_${PN} += " \ |
71 | ${OE_QMAKE_PATH_LIBS}/*.a \ | ||
72 | " | ||
73 | |||
74 | FILES_${PN}-tools = " \ | ||
75 | ${libdir}/lib*${SOLIBS} \ | ||
76 | ${OE_QMAKE_PATH_BINS}/* \ | ||
77 | ${SDKPATHNATIVE}/environment-setup.d \ | 66 | ${SDKPATHNATIVE}/environment-setup.d \ |
78 | ${datadir}/cmake \ | ||
79 | " | 67 | " |
80 | 68 | ||
81 | # qttools binaries are placed in a subdir of bin in order to avoid | 69 | # qttools binaries are placed in a subdir of bin in order to avoid |
82 | # collisions with qt4. This would trigger debian.bbclass to rename the | 70 | # collisions with qt4. This would trigger debian.bbclass to rename the |
83 | # package, since it doesn't detect binaries in subdirs. Explicitly | 71 | # package, since it doesn't detect binaries in subdirs. Explicitly |
84 | # disable package auto-renaming for the tools-package. | 72 | # disable package auto-renaming for the tools-package. |
85 | DEBIAN_NOAUTONAME_${PN}-tools = "1" | 73 | DEBIAN_NOAUTONAME_${PN} = "1" |
86 | 74 | ||
87 | QT_CONFIG_FLAGS += " \ | 75 | QT_CONFIG_FLAGS += " \ |
88 | -shared \ | 76 | -shared \ |